summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2023-06-27 10:08:35 +0100
committerChristopher Baines <mail@cbaines.net>2023-07-10 08:25:57 +0100
commit21d2e4621128e2fe0d45bed55b91305837c29ece (patch)
tree2a5c4c31eba19037c39c659d3ceb35df482d5dde /gnu/packages/ruby.scm
parentbcc615473d13e73fd22f0f0c41182a6c004c9ad2 (diff)
gnu: ruby-sqlite3: Update to 1.6.3.
* gnu/packages/ruby.scm (ruby-sqlite3): Update to 1.6.3. [source]: Switch to the Git repository to aid running tests. [arguments]: Update style and adjust. [native-inputs]: Add ruby-ruby-memcheck, ruby-rake-compiler and ruby-rake-compiler-dock.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm35
1 files changed, 25 insertions, 10 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index de45e3a345..521db0edf6 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -10582,25 +10582,40 @@ neither too verbose nor too minimal.")
(define-public ruby-sqlite3
(package
(name "ruby-sqlite3")
- (version "1.4.4")
+ (version "1.6.3")
(source
(origin
- (method url-fetch)
- (uri (rubygems-uri "sqlite3" version))
+ (method git-fetch) ;for tests
+ (uri (git-reference
+ (url "https://github.com/sparklemotion/sqlite3-ruby")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1z1wa639c278bsipczn6kv8b13fj85pi8gk7x462chqx6k0wm0ax"))))
+ "0ijj8z8fpk2lczydkxv71k250g5gd8ip8klsscxc9f16b01gh9qs"))))
(build-system ruby-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'check 'add-gemtest-file
- ;; This file exists in the repository but is not distributed.
- (lambda _ (invoke "touch" ".gemtest"))))))
+ (list
+ #:gem-flags #~(list "--" "--enable-system-libraries")
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'check)
+ (add-after 'install 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (setenv "GEM_PATH"
+ (string-append (getenv "GEM_PATH") ":"
+ #$output "/lib/ruby/vendor_ruby"))
+ (invoke "rake" "test")))))))
+ (propagated-inputs
+ (list ruby-mini-portile-2))
(inputs
(list sqlite))
(native-inputs
- (list ruby-hoe ruby-rake-compiler ruby-mini-portile-2))
+ (list ruby-hoe
+ ruby-ruby-memcheck
+ ruby-rake-compiler
+ ruby-rake-compiler-dock))
(synopsis "Interface with SQLite3 databases")
(description
"This module allows Ruby programs to interface with the SQLite3 database