summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorgemmaro <gemmaro.dev@gmail.com>2023-07-09 14:57:17 +0900
committerChristopher Baines <mail@cbaines.net>2023-07-10 12:39:34 +0100
commit40bac1a5577308ebf4cb81a1f4171baa4134df7e (patch)
tree4bf99b452bdb1ff0f1154568971c63a9298ca468 /gnu/packages/ruby.scm
parentd0296970fb8ed97ac17bd4c580351af961a8c0fb (diff)
gnu: Add ruby-bcrypt-pbkdf.
* gnu/packages/ruby.scm (ruby-bcrypt-pbkdf): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index a25126c5df..f2111ee858 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -11567,6 +11567,33 @@ secure hash algorithm for hashing passwords.")
(home-page "https://github.com/bcrypt-ruby/bcrypt-ruby")
(license license:expat)))
+(define-public ruby-bcrypt-pbkdf
+ (package
+ (name "ruby-bcrypt-pbkdf")
+ (version "1.1.0")
+ (source (origin
+ (method url-fetch)
+ (uri (rubygems-uri "bcrypt_pbkdf" version))
+ (sha256
+ (base32
+ "0ndamfaivnkhc6hy0yqyk2gkwr6f3bz6216lh74hsiiyk3axz445"))))
+ (build-system ruby-build-system)
+ (arguments
+ (list #:phases #~(modify-phases %standard-phases
+ (add-before 'build 'compile
+ (lambda _
+ (invoke "rake" "compile"))))))
+ (native-inputs (list ruby-minitest ruby-rake-compiler
+ ruby-rake-compiler-dock ruby-rdoc))
+ (synopsis "Reading password encrypted Ed25519 keys in Ruby")
+ (description
+ "This gem implements @samp{bcrypt_pbkdf}, which is a variant of
+PBKDF2 (Password-Based Key Derivation Function 2) with bcrypt-based
+pseudorandom function. This is currently used by @samp{net-ssh} to
+read password encrypted Ed25519 keys.")
+ (home-page "https://github.com/net-ssh/bcrypt_pbkdf-ruby")
+ (license license:expat)))
+
(define-public ruby-bio-commandeer
(package
(name "ruby-bio-commandeer")