summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2023-06-22 10:52:55 +0100
committerChristopher Baines <mail@cbaines.net>2023-07-10 08:25:56 +0100
commit68238b73b346bbf117cafc3bc0b9d00ef4a01e5f (patch)
treed7a408b9550b55b97a28079a5fd0c5f23d0847b9 /gnu/packages/ruby.scm
parent84af221d00a58c9e14d472a0f653d79e7f0ff61f (diff)
gnu: Add ruby-psych.
* gnu/packages/ruby.scm (ruby-psych): New variable.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 371c21f5a3..6a8bcda92a 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -7509,6 +7509,33 @@ process tree data structure for the current host.")
;; There is no mention of the "or later" clause.
(license license:gpl2)))
+(define-public ruby-psych
+ (package
+ (name "ruby-psych")
+ (version "5.1.0")
+ (source (origin
+ (method git-fetch) ;for tests
+ (uri (git-reference
+ (url "https://github.com/ruby/psych")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0m3668y79jcv2h9p7w74awwdyz13rpfr24w4nzh3iz96kxwssz83"))))
+ (build-system ruby-build-system)
+ (inputs
+ (list libyaml))
+ (native-inputs
+ (list ruby-rake-compiler))
+ (synopsis "Ruby YAML parser and emitter")
+ (description
+ "Psych is a YAML parser and emitter. Psych leverages libyaml for its
+YAML parsing and emitting capabilities. In addition to wrapping libyaml,
+Psych also knows how to serialize and de-serialize most Ruby objects to and
+from the YAML format.")
+ (home-page "https://github.com/ruby/psych")
+ (license license:expat)))
+
(define-public ruby-utils
(package
(name "ruby-utils")