summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2023-06-28 08:25:51 +0100
committerChristopher Baines <mail@cbaines.net>2023-07-10 08:25:59 +0100
commitb35bd82a80b20ce4061a007e1ef8035c3be27879 (patch)
tree1fb1a95c07e5819e3cd214f83a0926f4776cc353 /gnu/packages/ruby.scm
parentc6960691b8523a2beb320d2765ab741f313092d0 (diff)
gnu: ruby-tilt: Update to 2.0.11.
* gnu/packages/ruby.scm (ruby-tilt): Update to 2.0.11. [arguments]: Update style, patch some tests, remove more gems from the Gemfile, and set SASS_IMPLEMENTATION to sassc.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm58
1 files changed, 37 insertions, 21 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 4c536ff828..306e3699d6 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -7061,7 +7061,7 @@ intended for use with event loops such as async.")
(define-public ruby-tilt
(package
(name "ruby-tilt")
- (version "2.0.10")
+ (version "2.0.11")
(source
(origin
(method git-fetch) ;the distributed gem lacks tests
@@ -7071,28 +7071,44 @@ intended for use with event loops such as async.")
(file-name (git-file-name name version))
(sha256
(base32
- "0adb7fg7925n2rd9a8kkqz3mgylw2skp9hkh9qc1rnph72mqsm6r"))))
+ "0a75s6ci2rwai5q1bnlqbz8kxqnfp2497jhkcry1n4g29lcxq9ja"))))
(build-system ruby-build-system)
(arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'remove-some-dependencies
- (lambda _
- (substitute* "Gemfile"
- ;; TODO ronn is used for generating the manual
- (("gem 'ronn'.*") "\n")
- ;; ruby-haml has a runtime dependency on ruby-tilt, so don't
- ;; pass it in as a native-input
- (("gem 'haml'.*") "\n")
- ;; TODO Not all of these gems are packaged for Guix yet:
- ;; less, coffee-script, livescript, babel-transpiler,
- ;; typescript-node
- (("if can_execjs") "if false")
- ;; Disable the secondary group to reduce the number of
- ;; dependencies. None of the normal approaches work, so patch
- ;; the Gemfile instead.
- (("group :secondary") "[].each"))
- #t)))))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-tests
+ (lambda _
+ ;; Patch some tests
+ (substitute* "test/tilt_sasstemplate_test.rb"
+ (("}\",") "}
+\","))))
+ (add-after 'unpack 'remove-some-dependencies
+ (lambda _
+ (substitute* "Gemfile"
+ (("gem 'less'") "\n")
+ (("gem 'coffee-script'") "\n")
+ (("gem 'livescript'") "\n")
+ (("gem 'babel-transpiler'") "\n")
+ (("gem 'typescript-node'") "\n")
+ (("gem 'typescript-node'") "\n")
+ (("gem 'duktape'.*") "\n")
+ ;; TODO ronn is used for generating the manual
+ (("gem 'ronn'.*") "\n")
+ ;; ruby-haml has a runtime dependency on ruby-tilt, so don't
+ ;; pass it in as a native-input
+ (("gem 'haml'.*") "\n")
+ ;; TODO Not all of these gems are packaged for Guix yet:
+ ;; less, coffee-script, livescript, babel-transpiler,
+ ;; typescript-node
+ (("if can_execjs") "if false")
+ ;; Disable the secondary group to reduce the number of
+ ;; dependencies. None of the normal approaches work, so patch
+ ;; the Gemfile instead.
+ (("group :secondary") "[].each"))))
+ (add-before 'check 'set-SASS_IMPLEMENTATION
+ (lambda _
+ (setenv "SASS_IMPLEMENTATION" "sassc"))))))
(propagated-inputs
(list ruby-pandoc-ruby ruby-sassc))
(native-inputs