summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-07-14 00:17:41 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-07-17 23:01:33 -0400
commit668617923b63375e9dc093909d67a3a11df5732a (patch)
tree9a0b4933bbbaae7c39cae20a2385246777b81678 /gnu/packages/ruby.scm
parentc164c402a1899ffd2b2caba541b51e05855e94b8 (diff)
gnu: Add ruby-rubocop-performance.
* gnu/packages/ruby.scm (ruby-rubocop-performance): New variable.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 8b87449d7d..5666e0c1e9 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -1440,6 +1440,28 @@ Grammar (PEG) parser generator Domain Specific Language (DSL).")
(home-page "https://github.com/cjheath/treetop")
(license license:expat)))
+(define-public ruby-rubocop-performance
+ (package
+ (name "ruby-rubocop-performance")
+ (version "1.7.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "rubocop-performance" version))
+ (sha256
+ (base32
+ "04r8d4x62ygv17spvz9yyfxbmbf8qxwhijs0xycfvzr0q4pyg9sw"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:tests? #f)) ;no test suite in the distributed gem
+ (propagated-inputs
+ `(("ruby-rubocop" ,ruby-rubocop)))
+ (synopsis "Performance optimizations checkers for Ruby code")
+ (description "This package provides a collection of RuboCop cops to check
+for performance optimizations in Ruby code.")
+ (home-page "https://docs.rubocop.org/rubocop-performance/")
+ (license license:expat)))
+
(define-public ruby-ast
(package
(name "ruby-ast")