summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2017-10-10 20:08:09 +0100
committerChristopher Baines <mail@cbaines.net>2018-03-03 12:51:26 +0000
commitd0afff263c546fa7ef132b09ef04af7d178cd2ae (patch)
treea2721b16263d9afc3c364875104cc27d10b477f6 /gnu/packages/ruby.scm
parentfe5dd5f44659139b7327a3cf887dbb03741e4e42 (diff)
gnu: Add ruby-cztop.
* gnu/packages/ruby.scm (ruby-cztop): New variable.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index a9725af81e..f94ac54001 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -676,6 +676,44 @@ used by higher level bindings like those provided by CZTop.")
"https://github.com/paddor/czmq-ffi-gen")
(license license:isc)))
+(define-public ruby-cztop
+ (package
+ (name "ruby-cztop")
+ (version "0.12.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "cztop" version))
+ (sha256
+ (base32
+ "0yqbpaiw5d7f271d73lyrsh8xpx6n4zi6xqwfgi00dacxrq3s3fa"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:test-target "spec"
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-lib_paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "lib/cztop/poller/zmq.rb"
+ (("lib\\_paths = \\[.*\\]")
+ (string-append "lib_paths = ['"
+ (assoc-ref inputs "zeromq") "/lib"
+ "']"))))))))
+ (native-inputs
+ `(("bundler" ,bundler)
+ ("ruby-rspec" ,ruby-rspec)))
+ (inputs
+ `(("zeromq" ,zeromq)))
+ (propagated-inputs
+ `(("ruby-czmq-ffi-gen" ,ruby-czmq-ffi-gen)))
+ (synopsis "CZMQ Ruby bindings")
+ (description
+ "CZMQ Ruby bindings, based on the generated low-level FFI bindings of
+CZMQ. The focus of of CZTop is on being easy to use and providing first class
+support for security mechanisms.")
+ (home-page "https://github.com/paddor/cztop")
+ (license license:isc)))
+
(define-public ruby-saikuro-treemap
(package
(name "ruby-saikuro-treemap")