summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2016-08-07 09:39:07 +1000
committerBen Woodcroft <donttrustben@gmail.com>2016-08-10 15:36:33 +1000
commit44514637ca848c29568c51d7aea0d4cbf056b0e1 (patch)
tree52114243b8dc8d7fad1f23c9aa23f606bea58de6 /gnu/packages/ruby.scm
parent29f49403a9b34899a5eeeffac3cca50217955c4f (diff)
gnu: ruby-gherkin3: Rename to ruby-gherkin and update to 4.0.0.
* gnu/packages/ruby.scm (ruby-gherkin3): Rename to ruby-gherkin and update to 4.0.0. (ruby-cucumber-core)[propagated-inputs]: Adjust accordingly.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 376120685a..bff0d3c88d 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -2973,26 +2973,26 @@ Ruby classes.")
(home-page "https://ms-ati.github.io/docile/")
(license license:expat)))
-(define-public ruby-gherkin3
+(define-public ruby-gherkin
(package
- (name "ruby-gherkin3")
- (version "3.1.1")
+ (name "ruby-gherkin")
+ (version "4.0.0")
(source
(origin
(method url-fetch)
- (uri (rubygems-uri "gherkin3" version))
+ (uri (rubygems-uri "gherkin" version))
(sha256
(base32
- "0xsyxhqa1gwcxzvsdy4didaiq5vam8ma3fbwbw2w60via4k6r1z9"))))
+ "1ripjv97hg746xszx9isal8z8vrlb98asc2rdxl291b3hr6pj0pr"))))
(build-system ruby-build-system)
(native-inputs
`(("bundler" ,bundler)))
(arguments
'(#:tests? #f)) ; needs simplecov, among others
(synopsis "Gherkin parser for Ruby")
- (description "Gherkin 3 is a parser and compiler for the Gherkin language.
-It is intended to replace Gherkin 2 and be used by all Cucumber
-implementations to parse '.feature' files.")
+ (description "Gherkin is a parser and compiler for the Gherkin language.
+It is intended be used by all Cucumber implementations to parse '.feature'
+files.")
(home-page "https://github.com/cucumber/gherkin3")
(license license:expat)))
@@ -3009,7 +3009,7 @@ implementations to parse '.feature' files.")
"0qj2fsqvp94nggnikbnrfvnmzr1pl6ifmdsxj69kdw1kkab30jjr"))))
(build-system ruby-build-system)
(propagated-inputs
- `(("ruby-gherkin3" ,ruby-gherkin3)))
+ `(("ruby-gherkin" ,ruby-gherkin)))
(native-inputs
`(("bundler" ,bundler)))
(arguments