summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2015-12-29 14:36:20 +1000
committerBen Woodcroft <donttrustben@gmail.com>2016-01-26 16:06:10 +1000
commit120fc74b21861138e859f740fbeb02afe3f43a45 (patch)
treea0442100512f059c8e3edb14c1e493c66e694868 /gnu/packages/ruby.scm
parent90fcedf22030655f0c79fec663276a9e5228c217 (diff)
gnu: Add ruby-qed.
* gnu/packages/ruby.scm (ruby-qed): New variable.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index bd03d499a0..53da3fa4f5 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -3053,3 +3053,36 @@ foundational assertions framework for other assertion and test frameworks to
make use of.")
(home-page "http://rubyworks.github.io/brass")
(license license:bsd-2)))
+
+(define-public ruby-qed
+ (package
+ (name "ruby-qed")
+ (version "2.9.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "qed" version))
+ (sha256
+ (base32
+ "03h4lmlxpcya8j7s2cnyscqlx8v3xl1xgsw5y1wk1scxcgz2vbmr"))))
+ (build-system ruby-build-system)
+ (arguments
+ ;; Disable testing to break the cycle qed, ansi, qed, among others.
+ ;; Instead simply test that the executable runs using --copyright.
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (zero? (system* "ruby" "-Ilib" "bin/qed" "--copyright")))))))
+ (propagated-inputs
+ `(("ruby-ansi" ,ruby-ansi)
+ ("ruby-brass" ,ruby-brass)))
+ (synopsis "Test framework utilizing literate programming techniques")
+ (description
+ "@dfn{Quality Ensured Demonstrations} (QED) is a test framework for
+@dfn{Test Driven Development} (TDD) and @dfn{Behaviour Driven
+Development} (BDD) utilizing Literate Programming techniques. QED sits
+somewhere between lower-level testing tools like @code{Test::Unit} and
+requirement specifications systems like Cucumber.")
+ (home-page "http://rubyworks.github.io/qed")
+ (license license:bsd-2)))