summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-16 00:20:34 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-28 22:22:45 -0400
commit6574d0e1d11deb88fef6870d30e7c4b9adb1f106 (patch)
treed14e3204872c2000d81a48c2bfb8573a65225d3b /gnu/packages/ruby.scm
parent3c8c36f5435f6223b409425cac5838cefc5601ff (diff)
gnu: Add ruby-silent-stream.
* gnu/packages/ruby.scm (ruby-silent-stream): New variable.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 78a2fd07c4..1e8778b328 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -3629,6 +3629,24 @@ entries_with_correct_timestamps")
(home-page "https://github.com/rubyzip/rubyzip")
(license license:bsd-2)))
+(define-public ruby-silent-stream
+ (package
+ (name "ruby-silent-stream")
+ (version "1.0.6")
+ (source (origin
+ (method url-fetch)
+ (uri (rubygems-uri "silent_stream" version))
+ (sha256
+ (base32
+ "10381fpvjzfjvhgfyv700607fpa29firgf52w5w5536m4fh6x63m"))))
+ (build-system ruby-build-system)
+ (synopsis "ActiveSupport stream silencing without ActiveSupport")
+ (description "SilentStream is an extraction of some parts of
+ActiveSupport's Kernel Reporting Core Extentions around silencing IO
+streams.")
+ (home-page "https://github.com/pboling/silent_stream")
+ (license license:expat)))
+
(define-public ruby-simplecov-html
(package
(name "ruby-simplecov-html")