summaryrefslogtreecommitdiff
path: root/gnu/packages/rust-apps.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-05-22 21:19:28 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-08-14 19:38:03 +0300
commit0432b5907b9a836df572f17889e418a106f740fb (patch)
tree5fdff5b846a7b377e80fd682f2e5af2e438e0dba /gnu/packages/rust-apps.scm
parentc62b63a21008f964042ec5f0ca5d677cfca220e8 (diff)
gnu: fd: Adjust for newer rust-clap-4.
* gnu/packages/rust-apps.scm (fd)[arguments]: Add a phase to remove a feature-flag which was removed from the dependant project.
Diffstat (limited to 'gnu/packages/rust-apps.scm')
-rw-r--r--gnu/packages/rust-apps.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index 5a98f54e69..f572a3404e 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -520,6 +520,11 @@ also knows about symlinks, extended attributes, and Git.")
(setenv "CARGO_FEATURE_UNPREFIXED_MALLOC_ON_SUPPORTED_PLATFORMS" "1")
(setenv "JEMALLOC_OVERRIDE"
(string-append jemalloc "/lib/libjemalloc.so")))))
+ (add-after 'unpack 'adjust-feature-flags
+ (lambda _
+ ;; unstable-grouped was stablized in rust-clap 4.2.0
+ (substitute* "Cargo.toml"
+ ((".*unstable-grouped.*") ""))))
(add-after 'install 'install-extra
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))