summaryrefslogtreecommitdiff
path: root/gnu/packages/rust-apps.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-09-28 21:08:00 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-09-28 21:17:20 +0300
commit5b1897134877330e645ca572b93a50bb26ffb500 (patch)
tree41da0907c3b7707d5f6322de9049ced0f72cdaf1 /gnu/packages/rust-apps.scm
parent970fb81c6293a35a81608e5c1c377abeb6f1d69e (diff)
gnu: just: Install manpage.
* gnu/packages/rust-apps.scm (just)[arguments]: Add phase to install manpage.
Diffstat (limited to 'gnu/packages/rust-apps.scm')
-rw-r--r--gnu/packages/rust-apps.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index a18f7b31c7..7a5760a396 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -801,7 +801,12 @@ bar. It is also compatible with sway.")
(("/usr/bin/env")
(search-input-file inputs "/bin/env"))
(("/bin/echo")
- (search-input-file inputs "/bin/echo"))))))))
+ (search-input-file inputs "/bin/echo")))))
+ (add-after 'install 'install-manpage
+ (lambda* (#:key outputs #:allow-other-keys)
+ (install-file "man/just.1"
+ (string-append (assoc-ref outputs "out")
+ "/share/man/man1")))))))
(home-page "https://github.com/casey/just")
(synopsis "Just a command runner")
(description "This package provides @code{just}, a command runner.