summaryrefslogtreecommitdiff
path: root/gnu/packages/rust-apps.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-10-25 10:02:11 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-11-28 07:58:43 +0200
commit787038e9082a275ae8db76b9eead44c4a61d4799 (patch)
tree81d968d36cbc6101194779d5721edb3c7515d457 /gnu/packages/rust-apps.scm
parent03d55c13951abbb6f5a470894366b0421a7b9ec7 (diff)
gnu: alfis: Update to 0.8.4.
* gnu/packages/rust-apps.scm (alfis): Update to 0.8.4. [source]: Add snippet to use packaged versions of dependencies. [cargo-inputs]: Add rust-spmc-0.3, rust-winapi-0.3. Replace rust-simplelog-0.11 with 0.12, rust-toml-0.5 with 0.7, rust-signature-1 with 2, rust-base64-0.13 with 0.21, rust-sqlite-0.26 with 0.30, rust-uuid-0.8 with 1, rust-lru-0.7 with 0.9, rust-open-2 with 3, rust-thread-priority-0.4 with 0.10. [inputs]: Add sqlite
Diffstat (limited to 'gnu/packages/rust-apps.scm')
-rw-r--r--gnu/packages/rust-apps.scm31
1 files changed, 20 insertions, 11 deletions
diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index 6d90c8a90a..978b63ce57 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -81,6 +81,7 @@
#:use-module (gnu packages python-build)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages rust)
+ #:use-module (gnu packages sqlite)
#:use-module (gnu packages tls)
#:use-module (gnu packages version-control)
#:use-module (gnu packages webkit)
@@ -126,7 +127,7 @@ low-end hardware and serving many concurrent requests.")
(define-public alfis
(package
(name "alfis")
- (version "0.6.10")
+ (version "0.8.4")
(source
(origin
(method git-fetch)
@@ -135,7 +136,12 @@ low-end hardware and serving many concurrent requests.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1kgzz92mkyzn7mbsdpik1q21kl38i4almn01k99nww3p0vgx9514"))))
+ (base32 "1zqszjyiab0b76m2b8zfzpndg393hn311whq1fs9syfn53hp7nh4"))
+ (snippet
+ #~(begin (use-modules (guix build utils))
+ ;; Use a packaged version of web-view.
+ (substitute* "Cargo.toml"
+ (("git = .*,") "version = \"0.7.3\","))))))
(build-system cargo-build-system)
(arguments
`(#:cargo-test-flags
@@ -145,15 +151,15 @@ low-end hardware and serving many concurrent requests.")
#:cargo-inputs
(("rust-getopts" ,rust-getopts-0.2)
("rust-log" ,rust-log-0.4)
- ("rust-simplelog" ,rust-simplelog-0.11)
- ("rust-toml" ,rust-toml-0.5)
+ ("rust-simplelog" ,rust-simplelog-0.12)
+ ("rust-toml" ,rust-toml-0.7)
("rust-digest" ,rust-digest-0.10)
("rust-sha2" ,rust-sha2-0.10)
("rust-ed25519-dalek" ,rust-ed25519-dalek-1)
("rust-x25519-dalek" ,rust-x25519-dalek-1)
("rust-ecies-ed25519" ,rust-ecies-ed25519-0.5)
("rust-chacha20poly1305" ,rust-chacha20poly1305-0.9)
- ("rust-signature" ,rust-signature-1)
+ ("rust-signature" ,rust-signature-2)
("rust-blakeout" ,rust-blakeout-0.3)
("rust-num-cpus" ,rust-num-cpus-1)
("rust-byteorder" ,rust-byteorder-1)
@@ -161,23 +167,25 @@ low-end hardware and serving many concurrent requests.")
("rust-serde-json" ,rust-serde-json-1)
("rust-bincode" ,rust-bincode-1)
("rust-serde-cbor" ,rust-serde-cbor-0.11)
- ("rust-base64" ,rust-base64-0.13)
+ ("rust-base64" ,rust-base64-0.21)
("rust-num-bigint" ,rust-num-bigint-0.4)
("rust-num-traits" ,rust-num-traits-0.2)
("rust-chrono" ,rust-chrono-0.4)
("rust-rand" ,rust-rand-0.8)
("rust-rand-0.7" ,rust-rand-0.7) ;For ed25519-dalek
- ("rust-sqlite" ,rust-sqlite-0.26)
- ("rust-uuid" ,rust-uuid-0.8)
+ ("rust-sqlite" ,rust-sqlite-0.30)
+ ("rust-uuid" ,rust-uuid-1)
("rust-mio" ,rust-mio-0.8)
("rust-ureq" ,rust-ureq-2)
- ("rust-lru" ,rust-lru-0.7)
+ ("rust-lru" ,rust-lru-0.9)
("rust-derive-more" ,rust-derive-more-0.99)
("rust-lazy-static" ,rust-lazy-static-1)
+ ("rust-spmc" ,rust-spmc-0.3)
("rust-tinyfiledialogs" ,rust-tinyfiledialogs-3)
("rust-web-view" ,rust-web-view-0.7)
- ("rust-open" ,rust-open-2)
- ("rust-thread-priority" ,rust-thread-priority-0.4)
+ ("rust-open" ,rust-open-3)
+ ("rust-winapi" ,rust-winapi-0.3)
+ ("rust-thread-priority" ,rust-thread-priority-0.10)
("rust-winres" ,rust-winres-0.1))
#:cargo-development-inputs
(("rust-serde-bytes" ,rust-serde-bytes-0.11)
@@ -189,6 +197,7 @@ low-end hardware and serving many concurrent requests.")
gtk
glib
pango
+ sqlite
webkitgtk-with-libsoup2))
(home-page "https://github.com/Revertron/Alfis")
(synopsis "Alternative Free Identity System")