summaryrefslogtreecommitdiff
path: root/gnu/packages/rust-apps.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-10-28 16:39:33 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-11-28 07:59:07 +0200
commitbb108d7efd8eb7a5648547053b4a16ba67fe6a1a (patch)
tree722c67098fb9781ae72e12a82c1e13c1e7a43a7f /gnu/packages/rust-apps.scm
parentbc13c8c87be33c4bec06a3e3d771789a884f2f8c (diff)
gnu: rust-analyzer: Move to rust.scm.
* gnu/packages/rust-apps.scm (rust-analyzer): Move ... * gnu/packages/rust.scm (rust-analyzer): ... to here. Change-Id: I24db3731370f6e798b919409a32abec4a115c913
Diffstat (limited to 'gnu/packages/rust-apps.scm')
-rw-r--r--gnu/packages/rust-apps.scm28
1 files changed, 0 insertions, 28 deletions
diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index df0ea3c711..49223d1c8c 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -44,7 +44,6 @@
(define-module (gnu packages rust-apps)
#:use-module (guix build-system cargo)
#:use-module (guix build-system pyproject)
- #:use-module (guix build-system trivial)
#:use-module (guix deprecation)
#:use-module (guix download)
#:use-module (guix gexp)
@@ -81,7 +80,6 @@
#:use-module (gnu packages python)
#:use-module (gnu packages python-build)
#:use-module (gnu packages python-xyz)
- #:use-module (gnu packages rust)
#:use-module (gnu packages sqlite)
#:use-module (gnu packages tls)
#:use-module (gnu packages version-control)
@@ -1866,32 +1864,6 @@ work. This allows the client to be used in a much simpler way, with the
background agent taking care of maintaining the necessary state.")
(license license:expat)))
-(define-public rust-analyzer
- (package
- (name "rust-analyzer")
- (version (package-version rust))
- (source #f)
- (build-system trivial-build-system)
- (arguments
- (list
- #:modules '((guix build utils))
- #:builder
- #~(begin
- (use-modules (guix build utils))
- (let ((rust (assoc-ref %build-inputs "rust")))
- (install-file (string-append rust "/bin/rust-analyzer")
- (string-append #$output "/bin"))
- (copy-recursively (string-append rust "/share")
- (string-append #$output "/share"))))))
- (inputs
- (list (list rust "tools")))
- (home-page "https://rust-analyzer.github.io/")
- (synopsis "Experimental Rust compiler front-end for IDEs")
- (description "Rust-analyzer is a modular compiler frontend for the Rust
-language. It is a part of a larger rls-2.0 effort to create excellent IDE
-support for Rust.")
- (license (list license:expat license:asl2.0))))
-
;;; Note: keep in sync with our current Rust/Cargo version.
(define-public rust-cargo-c
(package