summaryrefslogtreecommitdiff
path: root/gnu/packages/rust-apps.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-03-11 14:02:36 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-06-19 11:19:43 +0300
commit2c2b1a90b171501ec2c00dd0b5e9df8a77f54a9b (patch)
treea2eb93316d7258c235a21182274c309922590307 /gnu/packages/rust-apps.scm
parentdf286a3016a9df258cb9d3542e00b1da8c25d9e9 (diff)
gnu: rust-cargo: Update to 0.77.0.
* gnu/packages/rust-apps.scm (rust-cargo): Update to 0.77.0. [cargo-inputs]: Add rust-regex-1, rust-rusqlite-0.30. Replace rust-gix-0.55 with 0.56, rust-itertools-0.11 with 0.12, rust-rustfix-0.6 with 0.7, rust-toml-edit-0.20 with 0.21, rust-windows-sys-0.48 with 0.52. Change-Id: I9428bf336cbfc013c8b683fbe5b6ab725c2d9aad
Diffstat (limited to 'gnu/packages/rust-apps.scm')
-rw-r--r--gnu/packages/rust-apps.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index 800d6f5dd5..6764e11e4a 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -2405,14 +2405,14 @@ background agent taking care of maintaining the necessary state.")
(define-public rust-cargo
(package
(name "rust-cargo")
- (version "0.76.0")
+ (version "0.77.0")
(source
(origin
(method url-fetch)
(uri (crate-uri "cargo" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "14yjyvj9bl6mlzx6bbi3igflgdrx1hil9ifnf1dl9xnm4mb2gjw6"))))
+ (base32 "1csj4mpzdjh26ah2vahxc0y6r31gbrv479kv5jm49larvrdrwfaa"))))
(build-system cargo-build-system)
(arguments
`(#:tests? #f ; unresolved import `cargo_test_support`
@@ -2438,7 +2438,7 @@ background agent taking care of maintaining the necessary state.")
("rust-flate2" ,rust-flate2-1)
("rust-git2" ,rust-git2-0.18)
("rust-git2-curl" ,rust-git2-curl-0.19)
- ("rust-gix" ,rust-gix-0.55)
+ ("rust-gix" ,rust-gix-0.56)
("rust-gix-features" ,rust-gix-features-0.35)
("rust-glob" ,rust-glob-0.3)
("rust-hex" ,rust-hex-0.4)
@@ -2449,7 +2449,7 @@ background agent taking care of maintaining the necessary state.")
("rust-ignore" ,rust-ignore-0.4)
("rust-im-rc" ,rust-im-rc-15)
("rust-indexmap" ,rust-indexmap-2)
- ("rust-itertools" ,rust-itertools-0.11)
+ ("rust-itertools" ,rust-itertools-0.12)
("rust-jobserver" ,rust-jobserver-0.1)
("rust-lazycell" ,rust-lazycell-1)
("rust-libc" ,rust-libc-0.2)
@@ -2462,7 +2462,9 @@ background agent taking care of maintaining the necessary state.")
("rust-pathdiff" ,rust-pathdiff-0.2)
("rust-pulldown-cmark" ,rust-pulldown-cmark-0.9)
("rust-rand" ,rust-rand-0.8)
- ("rust-rustfix" ,rust-rustfix-0.6)
+ ("rust-regex" ,rust-regex-1)
+ ("rust-rusqlite" ,rust-rusqlite-0.30)
+ ("rust-rustfix" ,rust-rustfix-0.7)
("rust-semver" ,rust-semver-1)
("rust-serde" ,rust-serde-1)
("rust-serde-untagged" ,rust-serde-untagged-0.1)
@@ -2474,11 +2476,10 @@ background agent taking care of maintaining the necessary state.")
("rust-supports-hyperlinks" ,rust-supports-hyperlinks-2)
("rust-syn" ,rust-syn-2)
("rust-tar" ,rust-tar-0.4)
- ("rust-tar" ,rust-tar-0.4)
("rust-tempfile" ,rust-tempfile-3)
("rust-time" ,rust-time-0.3)
("rust-toml" ,rust-toml-0.8)
- ("rust-toml-edit" ,rust-toml-edit-0.20)
+ ("rust-toml-edit" ,rust-toml-edit-0.21)
("rust-tracing" ,rust-tracing-0.1)
("rust-tracing-subscriber" ,rust-tracing-subscriber-0.3)
("rust-unicase" ,rust-unicase-2)
@@ -2486,7 +2487,7 @@ background agent taking care of maintaining the necessary state.")
("rust-unicode-xid" ,rust-unicode-xid-0.2)
("rust-url" ,rust-url-2)
("rust-walkdir" ,rust-walkdir-2)
- ("rust-windows-sys" ,rust-windows-sys-0.48))
+ ("rust-windows-sys" ,rust-windows-sys-0.52))
#:cargo-development-inputs (("rust-same-file" ,rust-same-file-1)
("rust-snapbox" ,rust-snapbox-0.4))))
(native-inputs