summaryrefslogtreecommitdiff
path: root/gnu/packages/rust-apps.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-03-11 10:28:40 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-03-11 10:30:26 +0200
commitf51760bd2a76e6efe6fa454f1d9f9ba650bc1c31 (patch)
tree00e5180f59ea25727f87d09260ded3a1bb8d7f9f /gnu/packages/rust-apps.scm
parenteae73b8b83b31f83cc73f40b1cd7dedf19c0e237 (diff)
gnu: Add rust-bindgen.
* gnu/packages/rust-apps.scm (rust-bindgen): New variable. Change-Id: I8b4a8e1d2c6a796143625b3de603cdec25723309
Diffstat (limited to 'gnu/packages/rust-apps.scm')
-rw-r--r--gnu/packages/rust-apps.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index 2a815afb76..c6104d5ebd 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -84,6 +84,7 @@
#:use-module (gnu packages jemalloc)
#:use-module (gnu packages kde)
#:use-module (gnu packages linux)
+ #:use-module (gnu packages llvm)
#:use-module (gnu packages networking)
#:use-module (gnu packages shells)
#:use-module (gnu packages ssh)
@@ -1865,6 +1866,44 @@ rebase.")
(base32
"006rn3fn4njayjxr2vd24g1awssr9i3894nbmfzkybx07j728vav"))))))
+;; This is the unversioned package of the latest version of bindgen.
+(define-public rust-bindgen
+ (package
+ (name "rust-bindgen")
+ (version "0.69.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "bindgen" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "18194611hn3k1dkxlha7a52sr8vmfhl9blc54xhj08cahd8wh3d0"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:install-source? #f
+ #:cargo-inputs (("rust-annotate-snippets" ,rust-annotate-snippets-0.9)
+ ("rust-bitflags" ,rust-bitflags-2)
+ ("rust-cexpr" ,rust-cexpr-0.6)
+ ("rust-clang-sys" ,rust-clang-sys-1)
+ ("rust-itertools" ,rust-itertools-0.10)
+ ("rust-lazy-static" ,rust-lazy-static-1)
+ ("rust-lazycell" ,rust-lazycell-1)
+ ("rust-log" ,rust-log-0.4)
+ ("rust-prettyplease" ,rust-prettyplease-0.2)
+ ("rust-proc-macro2" ,rust-proc-macro2-1)
+ ("rust-quote" ,rust-quote-1)
+ ("rust-regex" ,rust-regex-1)
+ ("rust-rustc-hash" ,rust-rustc-hash-1)
+ ("rust-shlex" ,rust-shlex-1)
+ ("rust-syn" ,rust-syn-2)
+ ("rust-which" ,rust-which-4))))
+ (inputs (list clang))
+ (home-page "https://rust-lang.github.io/rust-bindgen/")
+ (synopsis "Generate Rust FFI bindings to C and C++ libraries")
+ (description "This package can be used to automatically generate Rust FFI
+bindings to C and C++ libraries.")
+ (license license:bsd-3)))
+
(define-public sniffglue
(package
(name "sniffglue")