summaryrefslogtreecommitdiff
path: root/gnu/packages/rust.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2022-10-20 10:06:05 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-10-20 12:23:51 +0300
commit01be1973f464cb81cdece54f7858f0dee46abb50 (patch)
treed9f5437c1107b5e50d0bcba46b0ebb6882863b5e /gnu/packages/rust.scm
parentbf8b03667fa361bc03ab44fcbc66e99c812c0c68 (diff)
gnu: rust-bootstrap: Disable debug info during build.
This dramatically reduces the memory required to build Rust, and also speeds up the build. * gnu/packages/rust.scm (mrustc)[source]: Add snippet to remove building debug info with mrustc.
Diffstat (limited to 'gnu/packages/rust.scm')
-rw-r--r--gnu/packages/rust.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index d24ecbf2ae..6b40423709 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -15,6 +15,7 @@
;;; Copyright © 2021 (unmatched parenthesis <paren@disroot.org>
;;; Copyright © 2022 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2022 Jim Newsome <jnewsome@torproject.org>
+;;; Copyright © 2022 Mark H Weaver <mhw@netris.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -138,7 +139,14 @@
(file-name (git-file-name name (git-version version revision commit)))
(sha256
(base32
- "09rvm3zgx1d86gippl8qzh13m641ynbw9q0zsc90g0h1khd3z3b6")))))
+ "09rvm3zgx1d86gippl8qzh13m641ynbw9q0zsc90g0h1khd3z3b6"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Drastically reduces memory and build time requirements
+ ;; by disabling debug by default.
+ (substitute* (find-files "." "Makefile")
+ (("-g ") "")))))))
;;; Rust 1.54 is special in that it is built with mrustc, which shortens the
;;; bootstrap path.