summaryrefslogtreecommitdiff
path: root/gnu/packages/rust.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-05-09 16:54:29 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-05-09 16:54:29 +0300
commit3f00f46adad467f3008b2e645f76baf70adaad66 (patch)
tree74cf7f0a9015da73b882a1fe03320d676714995e /gnu/packages/rust.scm
parent7e421c1f5a40945418559e1a2e8ed94fd4bae7b2 (diff)
Revert "gnu: rust-bootstrap: Remove aarch64 as a supported architecture."
This reverts commit c56d57110de1412d3529940d4f856611d123da66. rust-bootstrap *IS* supported on aarch64-linux, and the build farm will catch up eventually.
Diffstat (limited to 'gnu/packages/rust.scm')
-rw-r--r--gnu/packages/rust.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index 30fb0e1e16..8e106a9927 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -360,9 +360,9 @@ safety and thread safety guarantees.")
;; therefore the build process needs 8GB of RAM while building.
;; It may support i686 soon:
;; <https://github.com/thepowersgang/mrustc/issues/78>.
- ;; XXX: The rust bootstrap is currently broken on riscv64 and fails to
- ;; build on CI for aarch64, remove them until this is fixed.
- (supported-systems '("x86_64-linux"))
+ ;; XXX: The rust bootstrap is currently broken on riscv64,
+ ;; remove it until this is fixed.
+ (supported-systems '("x86_64-linux" "aarch64-linux"))
;; Dual licensed.
(license (list license:asl2.0 license:expat))))