summaryrefslogtreecommitdiff
path: root/gnu/packages/rust.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-10-03 10:22:58 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-10-18 11:36:06 +0300
commit322b124936639ee9df8c32e3951b94be600ead80 (patch)
tree356f3bb40487e437d80d824cdac65ed89df022fd /gnu/packages/rust.scm
parentcf300075a5c4a855c1d0461ac8da54dcb3d0642e (diff)
gnu: rust: Fix test failures on some architectures.
* gnu/packages/rust.scm (rust)[arguments]: Adjust custom phase 'patch-process-tests to enable tests to pass on all architectures.
Diffstat (limited to 'gnu/packages/rust.scm')
-rw-r--r--gnu/packages/rust.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index 0dc60c8991..5e860057bc 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -845,10 +845,11 @@ safety and thread safety guarantees.")
;; emulation on aarch64 and riscv64 also fail on x86_64 in
;; Guix's build system. Skip them on all builds.
(substitute* "sys/unix/process/process_common/tests.rs"
- ,@(make-ignore-test-list
- '("fn test_process_mask"
- "fn test_process_group_posix_spawn"
- "fn test_process_group_no_posix_spawn")))))))
+ ;; We can't use make-ignore-test-list because we will get
+ ;; build errors due to the double [ignore] block.
+ (("target_arch = \"arm\"" arm)
+ (string-append "target_os = \"linux\",\n"
+ " " arm)))))))
(add-after 'unpack 'disable-interrupt-tests
(lambda _
;; This test hangs in the build container; disable it.