summaryrefslogtreecommitdiff
path: root/gnu/packages/rust.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-01-25 08:29:20 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:58:32 +0200
commit8ae188574f0c1d055a7a66e777cba7ef323293ae (patch)
tree9d9690c298ff796242eeca7a33bd8c1eeedae3e6 /gnu/packages/rust.scm
parentd31b86a698350738f0763e9850ed33dc6cfeefce (diff)
gnu: rust-bootstrap: Update supported-systems.
* gnu/packages/rust.scm (rust-bootstrap)[supported-systems]: Add riscv64-linux, powerpc64le-linux. Change-Id: I1584237c4a15ededee95a5d0e52c448f4aa0c9f3
Diffstat (limited to 'gnu/packages/rust.scm')
-rw-r--r--gnu/packages/rust.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index f792aa0061..1f129a93bd 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -377,9 +377,9 @@ safety and thread safety guarantees.")
;; therefore the build process needs 8GB of RAM while building.
;; It may support i686 soon:
;; <https://github.com/thepowersgang/mrustc/issues/78>.
- ;; XXX: The rust bootstrap is currently broken on riscv64,
- ;; remove it until this is fixed.
- (supported-systems '("x86_64-linux" "aarch64-linux"))
+ ;; List of systems where rust-bootstrap is explicitly known to build:
+ (supported-systems '("x86_64-linux" "aarch64-linux"
+ "riscv64-linux" "powerpc64le-linux"))
;; Dual licensed.
(license (list license:asl2.0 license:expat))))