summaryrefslogtreecommitdiff
path: root/gnu/packages/rust.scm
diff options
context:
space:
mode:
authorJim Newsome <jnewsome@torproject.org>2022-08-03 20:47:17 -0500
committerMarius Bakke <marius@gnu.org>2022-08-04 12:54:06 +0200
commitf9d947a38ced76ee34d3efb860678ac6bd23851b (patch)
treedd2ff0564de19eedb6527f72d339f7d69226280e /gnu/packages/rust.scm
parentcd7438c42233806aa83b078a34165960e373c4d9 (diff)
gnu: rust: decouple rust-1.57 and "rust"
* gnu/packages/rust.scm (rust-1.57, rust): decouple the definition of rust-1.57, which happens to be the current latest, from the definition of rust, which is always the latest. The latter re-enables tests and extra components, which should always be done only on the final public rust package, not specifically rust-1.57. Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu/packages/rust.scm')
-rw-r--r--gnu/packages/rust.scm23
1 files changed, 13 insertions, 10 deletions
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index 25472fefb0..a3691c2862 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021 (unmatched parenthesis <paren@disroot.org>
;;; Copyright © 2022 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2022 Jim Newsome <jnewsome@torproject.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -548,10 +549,18 @@ safety and thread safety guarantees.")
(generate-all-checksums "vendor"))))))))))
(define rust-1.57
- (let ((base-rust
- (rust-bootstrapped-package
- rust-1.56 "1.57.0"
- "06jw8ka2p3kls8p0gd4p0chhhb1ia1mlvj96zn78n7qvp71zjiim")))
+ (rust-bootstrapped-package
+ rust-1.56 "1.57.0" "06jw8ka2p3kls8p0gd4p0chhhb1ia1mlvj96zn78n7qvp71zjiim"))
+
+;;; Note: Only the latest versions of Rust are supported and tested. The
+;;; intermediate rusts are built for bootstrapping purposes and should not
+;;; be relied upon. This is to ease maintenance and reduce the time
+;;; required to build the full Rust bootstrap chain.
+;;;
+;;; Here we take the latest included Rust, make it public, and re-enable tests
+;;; and extra components such as rustfmt.
+(define-public rust
+ (let ((base-rust rust-1.57))
(package
(inherit base-rust)
(outputs (cons "rustfmt" (package-outputs base-rust)))
@@ -690,12 +699,6 @@ safety and thread safety guarantees.")
`("procps" ,procps)
(package-native-inputs base-rust))))))
-;;; Note: Only the latest versions of Rust are supported and tested. The
-;;; intermediate rusts are built for bootstrapping purposes and should not
-;;; be relied upon. This is to ease maintenance and reduce the time
-;;; required to build the full Rust bootstrap chain.
-(define-public rust rust-1.57)
-
(define-public rust-src
(hidden-package
(package