summaryrefslogtreecommitdiff
path: root/gnu/packages/sawfish.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-01-30 11:33:18 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-01-30 12:39:40 +0200
commit4cf1acc7f3033b50b0bf19e02c9f522d522d338c (patch)
tree9fd64956ee60304c15387eb394cd649e49f01467 /gnu/packages/sawfish.scm
parentedb8c09addd186d9538d43b12af74d6c7aeea082 (diff)
parent595b53b74e3ef57a1c0c96108ba86d38a170a241 (diff)
Merge remote-tracking branch 'origin/master' into core-updates
Conflicts: doc/guix.texi gnu/local.mk gnu/packages/admin.scm gnu/packages/base.scm gnu/packages/chromium.scm gnu/packages/compression.scm gnu/packages/databases.scm gnu/packages/diffoscope.scm gnu/packages/freedesktop.scm gnu/packages/gnome.scm gnu/packages/gnupg.scm gnu/packages/guile.scm gnu/packages/inkscape.scm gnu/packages/llvm.scm gnu/packages/openldap.scm gnu/packages/pciutils.scm gnu/packages/ruby.scm gnu/packages/samba.scm gnu/packages/sqlite.scm gnu/packages/statistics.scm gnu/packages/syndication.scm gnu/packages/tex.scm gnu/packages/tls.scm gnu/packages/version-control.scm gnu/packages/xml.scm guix/build-system/copy.scm guix/scripts/home.scm
Diffstat (limited to 'gnu/packages/sawfish.scm')
-rw-r--r--gnu/packages/sawfish.scm73
1 files changed, 37 insertions, 36 deletions
diff --git a/gnu/packages/sawfish.scm b/gnu/packages/sawfish.scm
index ab715b4a7d..1870a2950c 100644
--- a/gnu/packages/sawfish.scm
+++ b/gnu/packages/sawfish.scm
@@ -21,6 +21,7 @@
(define-module (gnu packages sawfish)
#:use-module ((guix licenses) #:select (gpl2+))
+ #:use-module (guix gexp)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu)
@@ -113,14 +114,14 @@ backend of Sawfish.")
(define-public sawfish
(package
(name "sawfish")
- (version "1.12.0")
+ (version "1.13.0")
(source (origin
(method url-fetch)
(uri (string-append "https://download.tuxfamily.org/sawfish/"
name "_" version ".tar.xz"))
(sha256
(base32
- "1z7awzgw8d15aw17kpbj460pcxq8l2rhkaxk47w7yg9qrmg0xja4"))
+ "0pdgf9w5vrn3kfqxwggikj4yqg82rpy8ji613zdhidacz9dkqsw1"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -131,44 +132,44 @@ backend of Sawfish.")
"REP_DL_LOAD_PATH=$(REP_DL_LOAD_PATH):"))
(substitute* "src/Makefile.in"
;; Install libraries for librep to $out/lib/rep.
- (("\\$\\(repexecdir\\)") "$(libdir)/rep"))
- #t))))
+ (("\\$\\(repexecdir\\)") "$(libdir)/rep"))))))
(build-system gnu-build-system)
(arguments
- '(#:tests? #f ; no tests
- #:phases
- (modify-phases %standard-phases
- (add-before 'configure 'patch-exec-rep
- (lambda _
- (substitute* '("lisp/sawfish/cfg/main.jl.in"
- "scripts/sawfish-about.jl.in"
- "scripts/sawfish-client.jl"
- "scripts/sawfish-menu.jl")
- (("exec rep") (string-append "exec " (which "rep"))))
- #t))
- (add-after 'install 'wrap-scripts
- ;; Wrap scripts with REP_DL_LOAD_PATH for finding rep-gtk
- ;; and sawfish.client.
- (lambda* (#:key outputs #:allow-other-keys)
- (define (wrap-script script)
- (let ((out (assoc-ref outputs "out")))
- (wrap-program (string-append out script)
- `("REP_DL_LOAD_PATH" =
- ,(list (getenv "REP_DL_LOAD_PATH")
- (string-append out "/lib/rep"))))))
- (for-each wrap-script
- (list "/bin/sawfish-about"
- "/bin/sawfish-client"
- "/bin/sawfish-config"
- "/lib/sawfish/sawfish-menu"))
- #t)))))
+ (list
+ #:tests? #f ; no tests
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'configure 'patch-exec-rep
+ (lambda _
+ (substitute* '("lisp/sawfish/cfg/main.jl.in"
+ "scripts/sawfish-about.jl.in"
+ "scripts/sawfish-client.jl"
+ "scripts/sawfish-menu.jl")
+ (("exec rep") (string-append "exec " (which "rep"))))))
+ (add-after 'install 'wrap-scripts
+ ;; Wrap scripts with REP_DL_LOAD_PATH for finding rep-gtk
+ ;; and sawfish.client.
+ (lambda* (#:key outputs #:allow-other-keys)
+ (define (wrap-script script)
+ (let ((out (assoc-ref outputs "out")))
+ (wrap-program (string-append out script)
+ `("REP_DL_LOAD_PATH" =
+ ,(list (getenv "REP_DL_LOAD_PATH")
+ (string-append out "/lib/rep"))))))
+ (for-each wrap-script
+ (list "/bin/sawfish-about"
+ "/bin/sawfish-client"
+ "/bin/sawfish-config"
+ "/lib/sawfish/sawfish-menu")))))))
(native-inputs
- `(("gettext" ,gettext-minimal)
- ("makeinfo" ,texinfo)
- ("pkg-config" ,pkg-config)
- ("which" ,which)))
+ (list gettext-minimal
+ texinfo
+ pkg-config
+ which))
(inputs
- (list libsm
+ (list gdk-pixbuf-xlib
+ gmp
+ libsm
libxft
libxinerama
libxrandr