summaryrefslogtreecommitdiff
path: root/gnu/packages/scheme.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-01-31 23:32:56 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-01-31 23:32:56 +0100
commit0747328e317de4bf936fab50e795d1e1523adfc1 (patch)
tree291d4f07a801b147d64faec31e4394c5cd46ce35 /gnu/packages/scheme.scm
parentdf09e1d6e71f68a8fb44bcc9f13e625f9f9701a5 (diff)
parentff75441fcf0ba1212b0342f933a8999bafe60f03 (diff)
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/scheme.scm')
-rw-r--r--gnu/packages/scheme.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index b836447668..bcaccb452c 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -1147,6 +1147,7 @@ generation.")
#:test-target "test"
#:phases
(modify-phases %standard-phases
+ (delete 'bootstrap)
(delete 'configure) ; No configure script
(replace 'install ; Makefile has no 'install phase
(lambda* (#:key outputs #:allow-other-keys)
@@ -1160,9 +1161,9 @@ generation.")
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(bin (string-append out "/bin")))
- (and
- (zero? (system* "./bootstrap.sh"))
- (install-file "flisp.boot" bin))))))))
+ (invoke "./bootstrap.sh")
+ (install-file "flisp.boot" bin)
+ #t))))))
(synopsis "Scheme-like lisp implementation")
(description
"@code{femtolisp} is a scheme-like lisp implementation with a