summaryrefslogtreecommitdiff
path: root/gnu/packages/scheme.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-10-23 12:19:30 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-10-23 14:37:36 +0300
commit27668c79dec10f7b9d71c257fe2db86abf9aba41 (patch)
tree7583b3f097c35441b8a97850892a73b8a24101a0 /gnu/packages/scheme.scm
parent71dcdaf31f6d3daf087425c2dba66abdcfd6a472 (diff)
gnu: gambit-c: Use 'modify-phases' syntax.
* gnu/packages/scheme.scm (gambit-c)[arguments]: Use 'modify-phases' syntax.
Diffstat (limited to 'gnu/packages/scheme.scm')
-rw-r--r--gnu/packages/scheme.scm20
1 files changed, 10 insertions, 10 deletions
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index de5b312a54..9cc34b08f9 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -532,16 +532,16 @@ of libraries.")
;; use >= 1 GB memory, but makes Gambit much faster.
'("--enable-single-host")
#:phases
- (alist-cons-before
- 'check 'fix-tests
- (lambda _
- (substitute* '("tests/makefile")
- ;; '-:' is how run-time options are set. 'tl' sets some terminal
- ;; option, which makes it fail in our build environment. It
- ;; recommends using 'd-' as a solution, which sets the REPL
- ;; interaction channel to stdin/stdout.
- (("gsi -:tl") "gsi -:d-,tl")))
- %standard-phases)))
+ (modify-phases %standard-phases
+ (add-before 'check 'fix-tests
+ (lambda _
+ (substitute* '("tests/makefile")
+ ;; '-:' is how run-time options are set. 'tl' sets some terminal
+ ;; option, which makes it fail in our build environment. It
+ ;; recommends using 'd-' as a solution, which sets the REPL
+ ;; interaction channel to stdin/stdout.
+ (("gsi -:tl") "gsi -:d-,tl"))
+ #t)))))
(home-page "http://www.iro.umontreal.ca/~gambit/")
(synopsis "Efficient Scheme interpreter and compiler")
(description