summaryrefslogtreecommitdiff
path: root/gnu/packages/scheme.scm
diff options
context:
space:
mode:
authorFederico Beffa <beffa@fbengineering.ch>2015-12-27 19:06:37 +0100
committerFederico Beffa <beffa@fbengineering.ch>2016-02-03 10:48:36 +0100
commitaf00e6335207b44056437eecab2e76c957c21a89 (patch)
tree253972f8e54957f4c34b5c41bf9e162d20636d04 /gnu/packages/scheme.scm
parente5045f303a0214c2e436c128ce3d6c59cf276f2a (diff)
gnu: mit-scheme: Convert to the 'modify-phases' syntax.
* gnu/packages/scheme.scm (mit-scheme): Do it.
Diffstat (limited to 'gnu/packages/scheme.scm')
-rw-r--r--gnu/packages/scheme.scm57
1 files changed, 26 insertions, 31 deletions
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index 70b229fa82..752dae226a 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -59,38 +59,33 @@
(arguments
`(#:tests? #f ; no "check" target
#:phases
- (alist-replace
- 'unpack
- (lambda* (#:key inputs #:allow-other-keys)
- (and (zero? (system* "tar" "xzvf"
- (assoc-ref inputs "source")))
- (chdir ,(mit-scheme-source-directory (%current-system)
- version))
- (begin
- ;; Delete these dangling symlinks since they break
- ;; `patch-shebangs'.
- (for-each delete-file
- (append '("src/lib/shim-config.scm")
- (find-files "src/lib/lib" "\\.so$")
- (find-files "src/lib" "^liarc-")
- (find-files "src/compiler" "^make\\.")))
- (chdir "src")
- #t)))
- (alist-replace
- 'build
- (lambda* (#:key system outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (if (or (string-prefix? "x86_64" system)
- (string-prefix? "i686" system))
- (zero? (system* "make" "compile-microcode"))
- (zero? (system* "./etc/make-liarc.sh"
- (string-append "--prefix=" out))))))
- %standard-phases))))
+ (modify-phases %standard-phases
+ (replace 'unpack
+ (lambda* (#:key inputs #:allow-other-keys)
+ (and (zero? (system* "tar" "xzvf"
+ (assoc-ref inputs "source")))
+ (chdir ,(mit-scheme-source-directory (%current-system)
+ version))
+ (begin
+ ;; Delete these dangling symlinks since they break
+ ;; `patch-shebangs'.
+ (for-each delete-file
+ (append '("src/lib/shim-config.scm")
+ (find-files "src/lib/lib" "\\.so$")
+ (find-files "src/lib" "^liarc-")
+ (find-files "src/compiler" "^make\\.")))
+ (chdir "src")
+ #t))))
+ (replace 'build
+ (lambda* (#:key system outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (if (or (string-prefix? "x86_64" system)
+ (string-prefix? "i686" system))
+ (zero? (system* "make" "compile-microcode"))
+ (zero? (system* "./etc/make-liarc.sh"
+ (string-append "--prefix=" out))))))))))
(inputs
- `(;; TODO: Build doc when TeX Live is available.
- ;; ("automake" ,automake)
- ;; ("texlive-core" ,texlive-core)
- ("texinfo" ,texinfo)
+ `(("texinfo" ,texinfo)
("m4" ,m4)
("libx11" ,libx11)