summaryrefslogtreecommitdiff
path: root/gnu/packages/scheme.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-10-23 11:36:27 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-10-23 14:37:36 +0300
commitfb685df8f893c7bfdd87a59b41e31568368b7785 (patch)
tree53d8120d89db0a7fe517246008105a2fad0ea6f1 /gnu/packages/scheme.scm
parent04014de6f555e21cccb056650f334be316390b5c (diff)
gnu: bigloo: Use 'modify-phases' syntax.
* gnu/packages/scheme.scm (bigloo)[arguments]: Use 'modify-phases' syntax.
Diffstat (limited to 'gnu/packages/scheme.scm')
-rw-r--r--gnu/packages/scheme.scm93
1 files changed, 46 insertions, 47 deletions
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index 30981b77a9..92f5affaf2 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -205,58 +205,57 @@ features an integrated Emacs-like editor and a large runtime library.")
(build-system gnu-build-system)
(arguments
`(#:test-target "test"
- #:phases (alist-replace
- 'configure
- (lambda* (#:key outputs #:allow-other-keys)
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
- (substitute* "configure"
- (("^shell=.*$")
- (string-append "shell=" (which "bash") "\n")))
+ (substitute* "configure"
+ (("^shell=.*$")
+ (string-append "shell=" (which "bash") "\n")))
- ;; Since libgc's pthread redirects are used, we end up
- ;; using libgc symbols, so we must link against it.
- ;; Reported on 2013-06-25.
- (substitute* "api/pthread/src/Makefile"
- (("^EXTRALIBS[[:blank:]]*=(.*)$" _ value)
- (string-append "EXTRALIBS = "
- (string-trim-right value)
- " -l$(GCLIB)_fth-$(RELEASE)"
- " -Wl,-rpath=" (assoc-ref outputs "out")
- "/lib/bigloo/" ,version)))
+ ;; Since libgc's pthread redirects are used, we end up
+ ;; using libgc symbols, so we must link against it.
+ ;; Reported on 2013-06-25.
+ (substitute* "api/pthread/src/Makefile"
+ (("^EXTRALIBS[[:blank:]]*=(.*)$" _ value)
+ (string-append "EXTRALIBS = "
+ (string-trim-right value)
+ " -l$(GCLIB)_fth-$(RELEASE)"
+ " -Wl,-rpath=" (assoc-ref outputs "out")
+ "/lib/bigloo/" ,version)))
- ;; Those variables are used by libgc's `configure'.
- (setenv "SHELL" (which "sh"))
- (setenv "CONFIG_SHELL" (which "sh"))
+ ;; Those variables are used by libgc's `configure'.
+ (setenv "SHELL" (which "sh"))
+ (setenv "CONFIG_SHELL" (which "sh"))
- ;; ... but they turned out to be overridden later, so work
- ;; around that.
- (substitute* (find-files "gc" "^configure-gc")
- (("sh=/bin/sh")
- (string-append "sh=" (which "sh"))))
+ ;; ... but they turned out to be overridden later, so work
+ ;; around that.
+ (substitute* (find-files "gc" "^configure-gc")
+ (("sh=/bin/sh")
+ (string-append "sh=" (which "sh"))))
- ;; The `configure' script doesn't understand options
- ;; of those of Autoconf.
- (let ((out (assoc-ref outputs "out")))
- (zero?
- (system* "./configure"
- (string-append "--prefix=" out)
- ;; FIXME: Currently fails, see
- ;; <http://article.gmane.org/gmane.lisp.scheme.bigloo/6126>.
- ;; "--customgc=no" ; use our libgc
- (string-append"--mv=" (which "mv"))
- (string-append "--rm=" (which "rm"))
- (string-append "--ldflags=-Wl,-rpath="
- (assoc-ref outputs "out")
- "/lib/bigloo/" ,version)))))
- (alist-cons-after
- 'install 'install-emacs-modes
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (dir (string-append out "/share/emacs/site-lisp")))
- (zero? (system* "make" "-C" "bmacs" "all" "install"
- (string-append "EMACSBRAND=emacs24")
- (string-append "EMACSDIR=" dir)))))
- %standard-phases))))
+ ;; The `configure' script doesn't understand options
+ ;; of those of Autoconf.
+ (let ((out (assoc-ref outputs "out")))
+ (zero?
+ (system* "./configure"
+ (string-append "--prefix=" out)
+ ;; FIXME: Currently fails, see
+ ;; <http://article.gmane.org/gmane.lisp.scheme.bigloo/6126>.
+ ;; "--customgc=no" ; use our libgc
+ (string-append"--mv=" (which "mv"))
+ (string-append "--rm=" (which "rm"))
+ (string-append "--ldflags=-Wl,-rpath="
+ (assoc-ref outputs "out")
+ "/lib/bigloo/" ,version))))))
+ (add-after 'install 'install-emacs-modes
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (dir (string-append out "/share/emacs/site-lisp")))
+ (zero? (system* "make" "-C" "bmacs" "all" "install"
+ (string-append "EMACSBRAND=emacs24")
+ (string-append "EMACSDIR=" dir)))))))))
(inputs
`(("emacs" ,emacs) ;UDE needs the X version of Emacs