summaryrefslogtreecommitdiff
path: root/gnu/packages/sdl.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-08-22 17:16:51 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-13 00:20:33 -0400
commitf24bf279d41fab25ceb3fcc88bcd5da6fb1404ae (patch)
tree017f659cb748aaa1a6172dccf209d89a04ec8d1a /gnu/packages/sdl.scm
parent3f25fcf84d5097dd66006db9204187376ea90e23 (diff)
gnu: sdl2: Update to 2.24.0, use gexps and remove input labels.
* gnu/packages/sdl.scm (sdl2): Update to 2.24.0. [arguments]: Use gexps. [inputs]: Use modify-inputs and remove labels.
Diffstat (limited to 'gnu/packages/sdl.scm')
-rw-r--r--gnu/packages/sdl.scm61
1 files changed, 32 insertions, 29 deletions
diff --git a/gnu/packages/sdl.scm b/gnu/packages/sdl.scm
index 1805de09f2..2523889a8d 100644
--- a/gnu/packages/sdl.scm
+++ b/gnu/packages/sdl.scm
@@ -13,6 +13,7 @@
;;; Copyright © 2019 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2020 Timotej Lazar <timotej.lazar@araneo.si>
;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
+;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -34,6 +35,7 @@
#:use-module (srfi srfi-1)
#:use-module (srfi srfi-26)
#:use-module (gnu packages)
+ #:use-module (guix gexp)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
@@ -110,46 +112,47 @@ joystick, and graphics hardware.")
(license license:lgpl2.1)))
(define-public sdl2
- (package (inherit sdl)
+ (package
+ (inherit sdl)
(name "sdl2")
- (version "2.0.14")
+ (version "2.24.0")
(source (origin
- (method url-fetch)
- (uri
- (string-append "https://libsdl.org/release/SDL2-"
- version ".tar.gz"))
- (sha256
- (base32
- "1g1jahknv5r4yhh1xq5sf0md20ybdw1zh1i15lry26sq39bmn8fq"))))
+ (method url-fetch)
+ (uri
+ (string-append "https://libsdl.org/release/SDL2-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "15vd9najhjh6s9z9hhx7zp51iby690a1g3h7kcwjvyb82x5w7r4i"))))
(arguments
(substitute-keyword-arguments (package-arguments sdl)
((#:configure-flags flags)
- `(append '("--disable-wayland-shared" "--enable-video-kmsdrm"
- "--disable-kmsdrm-shared")
- ,flags))
+ #~(append '("--disable-wayland-shared" "--enable-video-kmsdrm"
+ "--disable-kmsdrm-shared")
+ #$flags))
((#:make-flags flags ''())
- `(cons*
- ;; SDL dlopens libudev, so make sure it is in rpath. This overrides
- ;; the LDFLAG set in sdl’s configure-flags, which isn’t necessary
- ;; as sdl2 includes Mesa by default.
- (string-append "LDFLAGS=-Wl,-rpath,"
- (assoc-ref %build-inputs "eudev") "/lib")
- ,flags))))
+ #~(cons*
+ ;; SDL dlopens libudev, so make sure it is in rpath. This overrides
+ ;; the LDFLAG set in sdl’s configure-flags, which isn’t necessary
+ ;; as sdl2 includes Mesa by default.
+ (string-append "LDFLAGS=-Wl,-rpath,"
+ #$(this-package-input "eudev") "/lib")
+ #$flags))))
(inputs
;; SDL2 needs to be built with ibus support otherwise some systems
;; experience a bug where input events are doubled.
;;
;; For more information, see: https://dev.solus-project.com/T1721
- (append `(("dbus" ,dbus)
- ("eudev" ,eudev) ; for discovering input devices
- ("fcitx" ,fcitx) ; helps with CJK input
- ("glib" ,glib)
- ("ibus" ,ibus)
- ("libxkbcommon" ,libxkbcommon)
- ("libxcursor" ,libxcursor) ; enables X11 cursor support
- ("wayland" ,wayland)
- ("wayland-protocols" ,wayland-protocols))
- (package-inputs sdl)))
+ (modify-inputs (package-inputs sdl)
+ (append dbus
+ eudev ;for discovering input devices
+ fcitx ;helps with CJK input
+ glib
+ ibus
+ libxkbcommon
+ libxcursor ;enables X11 cursor support
+ wayland
+ wayland-protocols)))
(license license:bsd-3)))
(define-public libmikmod