summaryrefslogtreecommitdiff
path: root/gnu/packages/sdl.scm
diff options
context:
space:
mode:
authordan <i@dan.games>2023-08-09 01:49:52 +0800
committerJohn Kehayias <john.kehayias@protonmail.com>2023-11-05 22:09:53 -0500
commit50521348c89140705ca157a7d77f4acda24c26c7 (patch)
treee1f830d771c77d5d59bcfdd9def529d95267469e /gnu/packages/sdl.scm
parent37fc2c99e0067dfd669526c61dc10d014b89c08b (diff)
gnu: sdl2: Add vulkan-loader to rpath.
* gnu/packages/sdl.scm (sdl2)[arguments]: Append the path of libvulkan.so to rpath. [inputs]: Add vulkan-loader. Signed-off-by: John Kehayias <john.kehayias@protonmail.com> Change-Id: I17c8388f5f7b3bb063b79fd4981263994da129c0
Diffstat (limited to 'gnu/packages/sdl.scm')
-rw-r--r--gnu/packages/sdl.scm13
1 files changed, 9 insertions, 4 deletions
diff --git a/gnu/packages/sdl.scm b/gnu/packages/sdl.scm
index a4ee654097..ef0fe7f9ad 100644
--- a/gnu/packages/sdl.scm
+++ b/gnu/packages/sdl.scm
@@ -15,6 +15,7 @@
;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2023 Evgeny Pisemsky <evgeny@pisemsky.com>
+;;; Copyright © 2023 dan <i@dan.games>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -60,6 +61,7 @@
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages pulseaudio)
#:use-module (gnu packages gl)
+ #:use-module (gnu packages vulkan)
#:use-module (gnu packages xdisorg)
#:use-module (gnu packages xiph)
#:use-module (gnu packages xorg)
@@ -133,11 +135,13 @@ joystick, and graphics hardware.")
#$flags))
((#:make-flags flags ''())
#~(cons*
- ;; SDL dlopens libudev, so make sure it is in rpath. This overrides
- ;; the LDFLAG set in sdl’s configure-flags, which isn’t necessary
- ;; as sdl2 includes Mesa by default.
+ ;; SDL dlopens libudev and libvulkan, so make sure they are in
+ ;; rpath. This overrides the LDFLAG set in sdl’s configure-flags,
+ ;; which isn’t necessary as sdl2 includes Mesa by default.
(string-append "LDFLAGS=-Wl,-rpath,"
- #$(this-package-input "eudev") "/lib")
+ #$(this-package-input "eudev") "/lib"
+ ",-rpath,"
+ #$(this-package-input "vulkan-loader") "/lib")
#$flags))))
(inputs
;; SDL2 needs to be built with ibus support otherwise some systems
@@ -151,6 +155,7 @@ joystick, and graphics hardware.")
ibus-minimal
libxkbcommon
libxcursor ;enables X11 cursor support
+ vulkan-loader
wayland
wayland-protocols)))
(license license:bsd-3)))