summaryrefslogtreecommitdiff
path: root/gnu/packages/search.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-08-11 23:36:10 +0200
committerMarius Bakke <marius@gnu.org>2022-08-11 23:36:10 +0200
commit77eb3008e350c069e0ae8df6a91bf0ebdcfc2ac0 (patch)
treeb899e65aa79099be3f4b27dfcd565bb143681211 /gnu/packages/search.scm
parentf7e8be231806a904e6817e8ab3404b32f2511db2 (diff)
parentb50eaa67642ebc25e9c896f2e700c08610e0a5da (diff)
Merge branch 'staging' into core-updates
Diffstat (limited to 'gnu/packages/search.scm')
-rw-r--r--gnu/packages/search.scm41
1 files changed, 22 insertions, 19 deletions
diff --git a/gnu/packages/search.scm b/gnu/packages/search.scm
index 016142c7a9..2d652f5789 100644
--- a/gnu/packages/search.scm
+++ b/gnu/packages/search.scm
@@ -32,6 +32,7 @@
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix git-download)
+ #:use-module (guix gexp)
#:use-module (guix utils)
#:use-module (guix build-system gnu)
#:use-module (guix build-system perl)
@@ -672,23 +673,23 @@ bibliographic data and simple document and bibtex retrieval.")
(define-public ugrep
(package
(name "ugrep")
- (version "3.7.9")
+ (version "3.8.3")
(source (origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/Genivia/ugrep")
(commit (string-append "v" version))))
(sha256
- (base32 "0mj4da91r81drfl2nbgzl1krka6ksk7srjjvwgp55r6l265fk3b5"))
+ (base32 "03b3lahc3zzsznaqnrk47f1cnd5jwakvwrkz0r4m2crk09cpfv57"))
(file-name (git-file-name name version))
(modules '((guix build utils)))
(snippet
- '(begin
- (delete-file-recursively "bin") ; pre-built executables
- (for-each delete-file (find-files "tests" "^archive\\..*"))
- (for-each delete-file (find-files "tests" "^.*\\.pdf$"))
- (for-each delete-file (find-files "tests" "^.*\\.class$"))
- #t))))
+ #~(begin
+ (delete-file-recursively "bin") ; pre-built executables
+ (for-each (lambda (regexp)
+ (for-each delete-file
+ (find-files "tests" regexp)))
+ '("^archive" "\\.pdf$" "\\.class$"))))))
(build-system gnu-build-system)
(inputs
(list bzip2
@@ -696,18 +697,20 @@ bibliographic data and simple document and bibtex retrieval.")
lz4
lzip ;; lzma
pcre2
- zlib))
+ zlib
+ `(,zstd "lib")))
(arguments
- `(#:tests? #f ; no way to rebuild the binary input files
- #:test-target "test"
- #:phases
- (modify-phases %standard-phases
- (add-before 'check 'check-setup
- (lambda _
- ;; Unpatch shebangs in tests.
- (substitute* '("tests/Hello.bat"
- "tests/Hello.sh")
- (("#!/gnu/store/.*/bin/sh") "#!/bin/sh")))))))
+ (list
+ #:tests? #f ; no way to rebuild the binary input files
+ #:test-target "test"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'check-setup
+ (lambda _
+ ;; Unpatch shebangs in tests.
+ (substitute* '("tests/Hello.bat"
+ "tests/Hello.sh")
+ (("#!/gnu/store/.*/bin/sh") "#!/bin/sh")))))))
(home-page "https://github.com/Genivia/ugrep/")
(synopsis "Faster grep with an interactive query UI")
(description "Ugrep is a ultra fast searcher of file systems, text