summaryrefslogtreecommitdiff
path: root/gnu/packages/search.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-05-01 23:11:41 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-05-01 23:11:41 +0200
commit3b458d5462e6bbd852c2dc5c6670d5655abf53f5 (patch)
tree4f3ccec0de1c355134369333c17e948e3258d546 /gnu/packages/search.scm
parent2ca3fdc2db1aef96fbf702a2f26f5e18ce832038 (diff)
parent14da3daafc8dd92fdabd3367694c930440fd72cb (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/search.scm')
-rw-r--r--gnu/packages/search.scm30
1 files changed, 28 insertions, 2 deletions
diff --git a/gnu/packages/search.scm b/gnu/packages/search.scm
index 9969cad8ac..fe51900179 100644
--- a/gnu/packages/search.scm
+++ b/gnu/packages/search.scm
@@ -23,11 +23,12 @@
(define-module (gnu packages search)
#:use-module ((guix licenses)
- #:select (gpl2 gpl2+ gpl3+ lgpl2.1+ bsd-3 x11))
+ #:select (gpl2 gpl2+ gpl3+ lgpl2.1+ bsd-3 x11 perl-license))
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix utils)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system perl)
#:use-module (guix build-system python)
#:use-module (gnu packages)
#:use-module (gnu packages compression)
@@ -110,6 +111,31 @@ rich set of boolean query operators.")
(synopsis "Python bindings for the Xapian search engine library")
(license gpl2+)))
+(define-public perl-search-xapian
+ (package
+ (name "perl-search-xapian")
+ (version "1.2.25.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/O/OL/OLLY/"
+ "Search-Xapian-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0hpa8gi38j0ibq8af6dy69lm1bl5jnq76nsa69dbrzbr88l5m594"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-devel-leak" ,perl-devel-leak)))
+ (inputs
+ `(("xapian" ,xapian)))
+ (home-page "https://metacpan.org/release/Search-Xapian")
+ (synopsis "Perl XS frontend to the Xapian C++ search library")
+ (description
+ "Search::Xapian wraps most methods of most Xapian classes. The missing
+classes and methods should be added in the future. It also provides a
+simplified, more 'perlish' interface to some common operations.")
+ (license perl-license)))
+
(define-public libtocc
(package
(name "libtocc")
@@ -243,7 +269,7 @@ interfaces, or a C API.")
(home-page "https://pagure.io/mlocate")
(synopsis "Locate files on the file system")
(description
- "mlocate is a locate/updatedb implementation. The 'm' stands for
+ "mlocate is a locate/updatedb implementation. The @code{m} stands for
\"merging\": @code{updatedb} reuses the existing database to avoid rereading
most of the file system, which makes it faster and does not trash the system
caches as much. The locate(1) utility is intended to be completely compatible