summaryrefslogtreecommitdiff
path: root/gnu/packages/serialization.scm
diff options
context:
space:
mode:
authorAndy Tai <atai@atai.org>2023-09-02 21:55:18 -0700
committerRicardo Wurmus <rekado@elephly.net>2023-09-08 10:53:37 +0200
commit3eb77954f969df41c000e7018a6b598b9f562d8d (patch)
tree96f26c991ccaf9156c881e5fcce81a862cd6641b /gnu/packages/serialization.scm
parent2d366e309be381acc33c463b6bc55e3744e5c114 (diff)
gnu: tensorflow-lite: Update to 2.12.1.
* gnu/packages/algebra.scm (eigen-for-tensorflow-lite): Remove variable. * gnu/packages/machine-learning.scm (tensorflow-lite): Update to 2.12.1 [arguments]<configure-flags>: Turn on GPU and RUY use; Use cmake to find packages already in Guix as dependencies for absl-cpp, eigen, flatbuffer, neon2ssl, cpuinfo, ruy. [arguments]<phases>: Remove operations setting up absl-cpp, eigen, ruy, and neon2ssl as native inouts as now we use Guix's packages of these as dependencies. Do default build phase. Add steps to install C shared library and benchmark_model tool. [inputs]: Add cpuinfo, eigen, fp16, mesa-header, opencl, pthreadpool, ruy, vulkan and xnnpack as explicit inputs. [native-inputs]: Remove local setup of neon2ssl and ruy as we now use Guix's packages of these as explicit dependencies. * gnu/packages/serialization.scm (flatbuffers-next-shared): New variable, flatbuffers-next built with -fPIC as needed by tensorflow-lite. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu/packages/serialization.scm')
-rw-r--r--gnu/packages/serialization.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/serialization.scm b/gnu/packages/serialization.scm
index 9c114aaf39..c17d417d5e 100644
--- a/gnu/packages/serialization.scm
+++ b/gnu/packages/serialization.scm
@@ -811,6 +811,17 @@ game development and other performance-critical applications.")
(base32
"1z3a6l8g2y53i5xzraswfs2i0i3kk52zv7nzc2q3fgisbyiri3pz"))))))
+(define-public flatbuffers-next-shared
+ (package
+ (inherit flatbuffers-next)
+ (name "flatbuffers-shared")
+ (version "23.1.21")
+ (arguments
+ (substitute-keyword-arguments (package-arguments flatbuffers-next)
+ ((#:configure-flags flags)
+ ;; Compile with -fPIC, needed for shared lib.
+ #~(cons "-DFLATBUFFERS_CXX_FLAGS=-fPIC" #$flags))))))
+
(define-public python-feather-format
(package
(name "python-feather-format")