summaryrefslogtreecommitdiff
path: root/gnu/packages/shells.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-06-30 16:58:20 +0200
committerMarius Bakke <marius@gnu.org>2022-06-30 23:26:19 +0200
commit1a04f8c67725f1ac08e1d731a0f6629db5027889 (patch)
tree93a1415f59a77b2f0d41be1faee1050a2f73af0f /gnu/packages/shells.scm
parentbad74c24f0141a56f0c91d5bb3760d0c6717e8d8 (diff)
gnu: tcsh: Use G-expression.
* gnu/packages/shells.scm (tcsh)[arguments]: Rewrite as gexp.
Diffstat (limited to 'gnu/packages/shells.scm')
-rw-r--r--gnu/packages/shells.scm32
1 files changed, 14 insertions, 18 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index fb8feb3425..7ea9dfb483 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -413,16 +413,16 @@ written by Paul Haahr and Byron Rakitzis.")
(inputs
(list ncurses))
(arguments
- `(#:phases
- (modify-phases %standard-phases
- ,@(if (%current-target-system)
- '((add-before 'configure 'set-cross-cc
- (lambda _
- (substitute* "configure"
- (("CC_FOR_GETHOST=\"cc\"")
- "CC_FOR_GETHOST=\"gcc\""))
- #t)))
- '())
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ #$@(if (%current-target-system)
+ #~((add-before 'configure 'set-cross-cc
+ (lambda _
+ (substitute* "configure"
+ (("CC_FOR_GETHOST=\"cc\"")
+ "CC_FOR_GETHOST=\"gcc\"")))))
+ #~())
(add-before 'check 'patch-test-scripts
(lambda _
;; Take care of pwd
@@ -449,15 +449,11 @@ written by Paul Haahr and Byron Rakitzis.")
;; This file is ISO-8859-1 encoded.
(with-fluids ((%default-port-encoding #f))
(substitute* "tests/testsuite"
- (("/bin/sh") (which "sh"))))
- #t))
+ (("/bin/sh") (which "sh"))))))
(add-after 'install 'post-install
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let* ((out (assoc-ref %outputs "out"))
- (bin (string-append out "/bin")))
- (with-directory-excursion bin
- (symlink "tcsh" "csh"))
- #t))))))
+ (lambda _
+ (with-directory-excursion (string-append #$output "/bin")
+ (symlink "tcsh" "csh")))))))
(home-page "https://www.tcsh.org/")
(synopsis "Unix shell based on csh")
(description