summaryrefslogtreecommitdiff
path: root/gnu/packages/shells.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2021-02-06 21:13:52 -0500
committerTimothy Sample <samplet@ngyro.com>2022-03-19 13:33:06 -0600
commit892aac72a2e90682fe53075b03967217afb3df08 (patch)
treef2d83795de06ac1ae081a4ad5ee7b75c08f85952 /gnu/packages/shells.scm
parent0db2a6e74952ee2c99d47e9580aac9d7fe657b16 (diff)
gnu: gash-utils: Update to 0.2.0.
* gnu/packages/patches/gash-utils-ls-test.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it. * gnu/packages/shells.scm (gash-utils): Update to 0.2.0. [source]: Remove patch and Guile 3.0 snippet. * gnu/packages/commencement.scm (gash-utils-boot)[source]: Do not modify parent value. [arguments]: Add "env" to the list of scripts to create in the 'pre-configure' phase; add the "gash-utils" module directory in the 'configure', 'build', and 'install' phases.
Diffstat (limited to 'gnu/packages/shells.scm')
-rw-r--r--gnu/packages/shells.scm13
1 files changed, 2 insertions, 11 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 1652848705..9bd7ec291c 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -904,23 +904,14 @@ as part of the Guix bootstrap process.")
(define-public gash-utils
(package
(name "gash-utils")
- (version "0.1.0")
+ (version "0.2.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://savannah/gash/gash-utils-"
version ".tar.gz"))
(sha256
(base32
- "0ib2p52qmbac5n0s5bys4fiwim461ps546976l1n7pwbs0avh7fk"))
- (patches (search-patches "gash-utils-ls-test.patch"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; Allow builds with Guile 3.0.
- (substitute* "configure"
- (("search=\"2\\.2 2\\.0\"")
- "search=\"3.0 2.2 2.0\""))
- #t))))
+ "18ylb54l9lmaynapbncc1zhbsirhihznrxihhxgqrpqgyjkfbap6"))))
(build-system gnu-build-system)
(native-inputs
(list pkg-config))