summaryrefslogtreecommitdiff
path: root/gnu/packages/shells.scm
diff options
context:
space:
mode:
authorRyan Prior via Guix-patches via <guix-patches@gnu.org>2020-06-18 22:08:14 +0000
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-06-19 00:14:38 +0200
commite520aa8f41a8dbdbcee4e3537364f1d451583012 (patch)
treed03ab1ba493ea8a3cdfb305708a3d94129e3b896 /gnu/packages/shells.scm
parent7fd5f901f692fcaef2e9a262fcda082c96cf2775 (diff)
gnu: oil: Update to 0.8.pre6.
* gnu/packages/shells.scm (oil): Update to 0.8.pre6. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/shells.scm')
-rw-r--r--gnu/packages/shells.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 8f251bb850..109baacc30 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -803,14 +803,14 @@ Shell (pdksh).")
(package
(name "oil")
;; https://www.oilshell.org/blog/2020/04/release-0.8.pre4.html#comment-on-version-numbering
- (version "0.8.pre5")
+ (version "0.8.pre6")
(source
(origin
(method url-fetch)
(uri (string-append "https://www.oilshell.org/download/oil-"
version ".tar.gz"))
(sha256
- (base32 "02llxx10izxpv1y32qn8k6r0y7al01rzxjirc8h6x8nd9kiaqknl"))))
+ (base32 "11nfwn5b1w74hv78065jg2zm45mqzi59381b0f649j7n3g7yp3iq"))))
(build-system gnu-build-system)
(arguments
`(#:strip-binaries? #f ; strip breaks the binary
@@ -827,7 +827,7 @@ Shell (pdksh).")
(replace 'check
;; The tests are not distributed in the tarballs but upstream
;; recommends running this smoke test.
- ;; https://github.com/oilshell/oil/blob/release/0.8.pre5/INSTALL.txt#L38-L48
+ ;; https://github.com/oilshell/oil/blob/release/0.8.pre6/INSTALL.txt#L38-L48
(lambda _
(let* ((oil "_bin/oil.ovm"))
(invoke/quiet oil "osh" "-c" "echo hi")