summaryrefslogtreecommitdiff
path: root/gnu/packages/shells.scm
diff options
context:
space:
mode:
authorSören Tempel <soeren@soeren-tempel.net>2023-08-02 23:17:49 +0200
committerLudovic Courtès <ludo@gnu.org>2023-08-12 23:16:40 +0200
commit6a01add77044d21d6cd6499fbcda8cc00f7264a1 (patch)
tree35ad4d4badc6c9b4b2b4df1332bcccc1bc79da6c /gnu/packages/shells.scm
parentf4170f67cea035a244121c01e228f3ccb27bc585 (diff)
gnu: loksh: Update to 7.3.
* gnu/packages/shells.scm (loksh): Update to 7.3. [source]: Update style. Signed-off-by: Sören Tempel <soeren@soeren-tempel.net> Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/shells.scm')
-rw-r--r--gnu/packages/shells.scm34
1 files changed, 16 insertions, 18 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 62b682496e..944f6377de 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -788,26 +788,24 @@ The OpenBSD Korn Shell is a cleaned up and enhanced ksh.")
(define-public loksh
(package
(name "loksh")
- (version "6.9")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/dimkr/loksh")
- (commit version)
- ;; Include the ‘lolibc’ submodule, a static compatibility library
- ;; created for and currently used only by loksh.
- (recursive? #t)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0x33plxqhh5202hgqidgccz5hpg8d2q71ylgnm437g60mfi9z0px"))))
+ (version "7.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dimkr/loksh")
+ (commit version)
+ ;; Include the ‘lolibc’ submodule, a static compatibility library
+ ;; created for and currently used only by loksh.
+ (recursive? #t)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1miydvb79wagckchinp189l8i81f08lqajg5jngn77m4x4gwjf3n"))))
(build-system meson-build-system)
- (inputs
- (list ncurses))
- (native-inputs
- (list pkg-config))
+ (inputs (list ncurses))
+ (native-inputs (list pkg-config))
(arguments
- `(#:tests? #f)) ; no tests included
+ `(#:tests? #f)) ;no tests included
(home-page "https://github.com/dimkr/loksh")
(synopsis "Korn Shell from OpenBSD")
(description