summaryrefslogtreecommitdiff
path: root/gnu/packages/shells.scm
diff options
context:
space:
mode:
authorAndrew Whatson <whatson@tailcall.au>2023-08-11 21:48:40 +1000
committerLudovic Courtès <ludo@gnu.org>2023-08-12 23:14:11 +0200
commita479c0925a9158c9fae5931268d5c79e36f98634 (patch)
tree5c049c3200e0050fd4476b19c2f18b428abfcd2a /gnu/packages/shells.scm
parent83861b64e6ba66f4612e452f629704dbde0e267f (diff)
gnu: scsh: Fix version number and use gexps.
* gnu/packages/shells.scm (scsh)[version] Use latest upstream commit. Use git-version. Correct base version number to 0.7. [source]: Use git-file-name. [arguments]: Use gexps and remove trailing #t in phases. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/shells.scm')
-rw-r--r--gnu/packages/shells.scm32
1 files changed, 16 insertions, 16 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index aef22efd01..62b682496e 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -602,36 +602,36 @@ use of experts and novices alike.")
(license license:bsd-2)))
(define-public scsh
- (let ((commit "114432435e4eadd54334df6b37fcae505079b49f")
- (revision "1"))
+ (let ((commit "4acf6e4ed7b65b46186ef0c9c2a1e10bef8dc052")
+ (revision "0"))
(package
(name "scsh")
- (version (string-append "0.0.0-" revision "." (string-take commit 7)))
+ (version (git-version "0.7" revision commit))
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/scheme/scsh")
(commit commit)))
- (file-name (string-append name "-" version "-checkout"))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1ghk08akiz7hff1pndi8rmgamgcrn2mv9asbss9l79d3c2iaav3q"))
+ "1czrp808v5gs0ci5lmkp3wr3gfkrb3vd5b2iw2hz1bpqgaf6bxpv"))
(patches (search-patches "scsh-nonstring-search-path.patch"))))
(build-system gnu-build-system)
(arguments
- `(#:test-target "test"
- #:phases
- (modify-phases %standard-phases
- (add-before 'configure 'replace-rx
- (lambda* (#:key inputs #:allow-other-keys)
- (let* ((rx (assoc-ref inputs "scheme48-rx"))
- (rxpath (string-append rx "/share/scheme48-"
- ,(package-version scheme48)
+ (list
+ #:test-target "test"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'configure 'replace-rx
+ (lambda _
+ (let ((rxpath (string-append #$scheme48-rx
+ "/share/scheme48-"
+ #$(package-version scheme48)
"/rx")))
- (delete-file-recursively "rx")
- (symlink rxpath "rx"))
- #t)))))
+ (delete-file-recursively "rx")
+ (symlink rxpath "rx")))))))
(inputs
(list scheme48 scheme48-rx))
(native-inputs