summaryrefslogtreecommitdiff
path: root/gnu/packages/shells.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-07-24 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-07-24 02:00:00 +0200
commit171964da5bd3e85babad90ad81fb429944347dfd (patch)
treee177db1ef7a6d14508a57a774ed02c3ac7a6e134 /gnu/packages/shells.scm
parent3dab424a3d4bbd7c552fc848f05e0f497e2f562e (diff)
gnu: es: Use URL-FETCH/TARBOMB.
* gnu/packages/shells.scm (es)[source]: Use URL-FETCH/TARBOMB to let us… [arguments]: …delete the ad-hoc 're-enter-rootdir phase.
Diffstat (limited to 'gnu/packages/shells.scm')
-rw-r--r--gnu/packages/shells.scm10
1 files changed, 2 insertions, 8 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 21035498a6..a8a42f0544 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -363,7 +363,7 @@ has a small feature set similar to a traditional Bourne shell.")
(version "0.9.2")
(source
(origin
- (method url-fetch)
+ (method url-fetch/tarbomb)
(uri (string-append "https://github.com/wryun/es-shell/releases/"
"download/v" version "/es-" version ".tar.gz"))
(sha256
@@ -371,13 +371,7 @@ has a small feature set similar to a traditional Bourne shell.")
(file-name (string-append name "-" version ".tar.gz"))))
(build-system gnu-build-system)
(arguments
- `(#:test-target "test"
- #:phases
- (modify-phases %standard-phases
- (add-before 'configure 're-enter-rootdir
- ;; The tarball has no folder.
- (lambda _
- (chdir ".."))))))
+ (list #:test-target "test"))
(inputs
(list readline))
(native-inputs