summaryrefslogtreecommitdiff
path: root/gnu/packages/shells.scm
diff options
context:
space:
mode:
authorDavid Pflug <david@pflug.io>2023-08-12 07:45:26 -0400
committer宋文武 <iyzsong@member.fsf.org>2023-08-13 13:48:12 +0800
commita52dc9e5e3760e30dd5bda59c444b36fd383e855 (patch)
tree4782747d04922dcc4df29ff537d257644cac4d4e /gnu/packages/shells.scm
parent71f5552be28a810df5270b9fcaa6313354b8fa2e (diff)
gnu: oil: Update to 0.17.0.
* gnu/packages/shells.scm (oil): Update to 0.17.0. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu/packages/shells.scm')
-rw-r--r--gnu/packages/shells.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 944f6377de..8042fab12f 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -21,6 +21,7 @@
;;; Copyright © 2021, 2022 Felix Gruber <felgru@posteo.net>
;;; Copyright © 2022 Andrew Tropin <andrew@trop.in>
;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2023 David Pflug <david@pflug.io>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -856,7 +857,7 @@ Shell (pdksh).")
(define-public oil
(package
(name "oil")
- (version "0.15.0")
+ (version "0.17.0")
(source
;; oil's sources contain a modified version of CPython 2.7.13.
;; According to https://www.oilshell.org/blog/2017/05/05.html
@@ -869,7 +870,7 @@ Shell (pdksh).")
(uri (string-append "https://www.oilshell.org/download/oil-"
version ".tar.gz"))
(sha256
- (base32 "1yy4523lbwkb0abnnvp4v08nv94isxb16wjryrp820idb90c1zfb"))))
+ (base32 "01b67dq56iam44d7c81ba9w62jjnjx2z7wm928rkc1ff6bacm37r"))))
(build-system gnu-build-system)
(arguments
(list #:strip-binaries? #f ; strip breaks the binary