summaryrefslogtreecommitdiff
path: root/gnu/packages/shells.scm
diff options
context:
space:
mode:
authorStefan Reichoer <stefan@xsteve.at>2016-09-21 21:58:52 +0200
committerLeo Famulari <leo@famulari.name>2016-09-28 13:42:06 -0400
commit1d51585573f49105edd1a577ba53e86367ffd821 (patch)
tree43c45559a951a8ff8a70b1d9966a6468de910de4 /gnu/packages/shells.scm
parentb2fe918302de7a1e978cf820a55beb110362ecce (diff)
gnu: Add xonsh.
* gnu/packages/shells.scm (xonsh): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/shells.scm')
-rw-r--r--gnu/packages/shells.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 183ef7f289..c165f99d4c 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -33,6 +33,7 @@
#:use-module (gnu packages python)
#:use-module (gnu packages readline)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system python)
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module (guix licenses)
@@ -269,3 +270,25 @@ ksh, and tcsh.")
;; The whole thing is under an MIT/X11-style license, but there's one
;; command, 'Completion/Unix/Command/_darcs', which is under GPLv2+.
(license gpl2+)))
+
+(define-public xonsh
+ (package
+ (name "xonsh")
+ (version "0.4.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "xonsh" version))
+ (sha256
+ (base32
+ "0byxd9kjl99q2pyvjh9jy18l0di1i35wr0qqgnw4i6jh6ig3zcki"))))
+ (build-system python-build-system)
+ (home-page "http://xon.sh/")
+ (synopsis "Python-ish shell")
+ (description
+ "Xonsh is a Python-ish, BASHwards-looking shell language and command
+prompt. The language is a superset of Python 3.4+ with additional shell
+primitives that you are used to from Bash and IPython. It works on all major
+systems including Linux, Mac OSX, and Windows. Xonsh is meant for the daily
+use of experts and novices alike.")
+ (license bsd-2)))