summaryrefslogtreecommitdiff
path: root/gnu/packages/shells.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2016-08-03 01:13:24 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2016-08-03 04:54:29 +0200
commitd754347cb456510b23b65dc0a43737c1ad39ffcd (patch)
tree22e9121ad45ae4eceaf6d3cc19a7305a3ada10e7 /gnu/packages/shells.scm
parent9a57d3e6a19b56d9c4c7917c401878c15866be0c (diff)
gnu: tcsh: Move to shells.scm.
* gnu/packages/tcsh.scm (tcsh): Move from here ... * gnu/packages/shells.scm (tcsh): ... to here. * gnu/packages/tcsh.scm: Delete file. * gnu/local.mk (GNU_SYSTEM_MODULES): Remove tcsh.scm.
Diffstat (limited to 'gnu/packages/shells.scm')
-rw-r--r--gnu/packages/shells.scm62
1 files changed, 62 insertions, 0 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index cc0a8a5adb..b3fd5fa1cd 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -1,4 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
;;; Copyright © 2014, 2015 David Thompson <davet@gnu.org>
;;; Copyright © 2015 Jeff Mickey <j@codemac.net>
;;; Copyright © 2016 Tobias Geerinckx-Rice <me@tobias.gr>
@@ -19,7 +20,9 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages shells)
+ #:use-module (gnu packages)
#:use-module (gnu packages autotools)
+ #:use-module (gnu packages base)
#:use-module (gnu packages documentation)
#:use-module (gnu packages libedit)
#:use-module (gnu packages ncurses)
@@ -151,3 +154,62 @@ highlighting.")
has a small feature set similar to a traditional Bourne shell.")
(home-page "http://github.com/rakitzis/rc")
(license zlib)))
+
+(define-public tcsh
+ (package
+ (name "tcsh")
+ (version "6.18.01")
+ (source (origin
+ (method url-fetch)
+ ;; Old tarballs are moved to old/.
+ (uri (list (string-append "ftp://ftp.astron.com/pub/tcsh/"
+ "tcsh-" version ".tar.gz")
+ (string-append "ftp://ftp.astron.com/pub/tcsh/"
+ "old/tcsh-" version ".tar.gz")))
+ (sha256
+ (base32
+ "1a4z9kwgx1iqqzvv64si34m60gj34p7lp6rrcrb59s7ka5wa476q"))
+ (patches (search-patches "tcsh-fix-autotest.patch"))
+ (patch-flags '("-p0"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("autoconf" ,autoconf)
+ ("coreutils" ,coreutils)
+ ("ncurses" ,ncurses)))
+ (arguments
+ `(#:phases
+ (alist-cons-before
+ 'check 'patch-test-scripts
+ (lambda _
+ ;; Take care of pwd
+ (substitute* '("tests/commands.at" "tests/variables.at")
+ (("/bin/pwd") (which "pwd")))
+ ;; The .at files create shell scripts without shebangs. Erk.
+ (substitute* "tests/commands.at"
+ (("./output.sh") "/bin/sh output.sh"))
+ (substitute* "tests/syntax.at"
+ (("; other_script.csh") "; /bin/sh other_script.csh"))
+ ;; Now, let's generate the test suite and patch it
+ (system* "make" "tests/testsuite")
+
+ ;; This file is ISO-8859-1 encoded.
+ (with-fluids ((%default-port-encoding #f))
+ (substitute* "tests/testsuite"
+ (("/bin/sh") (which "sh")))))
+ (alist-cons-after
+ 'install 'post-install
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref %outputs "out"))
+ (bin (string-append out "/bin")))
+ (with-directory-excursion bin
+ (symlink "tcsh" "csh"))))
+ %standard-phases))))
+ (home-page "http://www.tcsh.org/")
+ (synopsis "Unix shell based on csh")
+ (description
+ "Tcsh is an enhanced, but completely compatible version of the Berkeley
+UNIX C shell (csh). It is a command language interpreter usable both as an
+interactive login shell and a shell script command processor. It includes a
+command-line editor, programmable word completion, spelling correction, a
+history mechanism, job control and a C-like syntax.")
+ (license bsd-4)))