summaryrefslogtreecommitdiff
path: root/gnu/packages/shells.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2021-02-07 13:36:31 -0500
committerTimothy Sample <samplet@ngyro.com>2022-03-19 13:33:06 -0600
commitee2f074d0b0f9c338a4e6abda7a544476cd41319 (patch)
treea50b9193813a5c6813beabd9e198013c984d97f7 /gnu/packages/shells.scm
parentca6993af91083733b7a280815a516c6e6cdf4b88 (diff)
gnu: gash: Update to 0.3.0.
* gnu/packages/shells.scm (gash): Update to 0.3.0. [source]: Remove Guile 3.0 snippet. [arguments]: Delete arguments. * gnu/packages/commencement.scm (gash-boot)[source]: Do not remove the Guile 3.0 snippet (it no longer exists).
Diffstat (limited to 'gnu/packages/shells.scm')
-rw-r--r--gnu/packages/shells.scm14
1 files changed, 2 insertions, 12 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 9bd7ec291c..d46a6549b8 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -870,29 +870,19 @@ scripts.")
(define-public gash
(package
(name "gash")
- (version "0.2.0")
+ (version "0.3.0")
(source
(origin (method url-fetch)
(uri (string-append "mirror://savannah/gash/gash-"
version ".tar.gz"))
(sha256
(base32
- "13m0yz5h9nj3x40mr6wr5xcpq1lscndfwcicw3skrz801025hhgf"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; Allow builds with Guile 3.0.
- (substitute* "configure"
- (("search=\"2\\.2 2\\.0\"")
- "search=\"3.0 2.2 2.0\""))
- #t))))
+ "1af2jz4a6rzsshi379wzw4b8d04zvfamdhfzip2pgmk821lyqsjl"))))
(build-system gnu-build-system)
(native-inputs
(list pkg-config))
(inputs
(list guile-3.0))
- (arguments
- '(#:make-flags '("XFAIL_TESTS=tests/redirects.org")))
(home-page "https://savannah.nongnu.org/projects/gash/")
(synopsis "POSIX-compatible shell written in Guile Scheme")
(description "Gash is a POSIX-compatible shell written in Guile