summaryrefslogtreecommitdiff
path: root/gnu/packages/skribilo.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-10-10 21:44:32 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-10-10 21:44:32 +0200
commit1c055d72585bd075e20ad0b41942d501d0b38656 (patch)
tree7baf50e22fb5f6c6d4b2fa7197596f68298eb691 /gnu/packages/skribilo.scm
parent565e24c4e4710a5b81cce5cfb619b3e474e7f65c (diff)
parentffb4da7ad5c0e9cc969e0e47a3b8f4d2eba4d6f3 (diff)
Merge branch 'staging'
Diffstat (limited to 'gnu/packages/skribilo.scm')
-rw-r--r--gnu/packages/skribilo.scm29
1 files changed, 15 insertions, 14 deletions
diff --git a/gnu/packages/skribilo.scm b/gnu/packages/skribilo.scm
index 458d91e569..87dc3558de 100644
--- a/gnu/packages/skribilo.scm
+++ b/gnu/packages/skribilo.scm
@@ -46,20 +46,21 @@
(assoc-ref %outputs "out")
"/share/guile/site/2.0"))
- #:phases (alist-cons-before
- 'configure 'pre-configure
- (lambda* (#:key inputs #:allow-other-keys)
- ;; Make sure the 'skribilo' command gets to see
- ;; Guile-Reader, even if Guile-Reader is not in the search
- ;; path.
- (let ((reader (assoc-ref inputs "guile-reader")))
- (substitute* "src/skribilo.in"
- (("^exec (.*) -c" _ things)
- (string-append "exec " things
- " -L " reader "/share/guile/site/2.0"
- " -C " reader "/share/guile/site/2.0"
- " -c")))))
- %standard-phases)
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'pre-configure
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; Make sure the 'skribilo' command gets to see
+ ;; Guile-Reader, even if Guile-Reader is not in the search
+ ;; path.
+ (let ((reader (assoc-ref inputs "guile-reader")))
+ (substitute* "src/skribilo.in"
+ (("^exec (.*) -c" _ things)
+ (string-append "exec " things
+ " -L " reader "/share/guile/site/2.0"
+ " -C " reader "/share/guile/site/2.0"
+ " -c"))))
+ #t)))
#:parallel-build? #f))