summaryrefslogtreecommitdiff
path: root/gnu/packages/slang.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-01-23 17:01:07 -0500
committerMark H Weaver <mhw@netris.org>2018-01-23 17:01:07 -0500
commita102d359a68ce7219a1880e47dd6f9332cbbce3a (patch)
treed879e718f08d776ad84c456c91a349e59941d1f2 /gnu/packages/slang.scm
parent07b8ea841e1e2eda5b367f35cf68d23d0520cc4d (diff)
parentf3a13a21e50fa3751fc39e5768ea6843bfc19df2 (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/slang.scm')
-rw-r--r--gnu/packages/slang.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/slang.scm b/gnu/packages/slang.scm
index 953291be26..b0a7ff0cfc 100644
--- a/gnu/packages/slang.scm
+++ b/gnu/packages/slang.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -79,14 +80,14 @@ slsh, which is part of the S-Lang distribution.")
(define-public newt
(package
(name "newt")
- (version "0.52.18")
+ (version "0.52.20")
(source (origin
(method url-fetch)
(uri (string-append "https://pagure.io/releases/"
name "/" name "-" version ".tar.gz"))
(sha256
(base32
- "07n9f2mqsjfj35wx5ldhvl9sqcjqpcl0g4fdd9mawmny9rihw6vp"))))
+ "1g3dpfnvaw7vljbr7nzq1rl88d6r8cmrvvng9inphgzwxxmvlrld"))))
(build-system gnu-build-system)
(outputs '("out" "python"))
(inputs
@@ -100,8 +101,9 @@ slsh, which is part of the S-Lang distribution.")
;; Set the correct RUNPATH in binaries.
(list (string-append "LDFLAGS=-Wl,-rpath=" %output "/lib"))
#:make-flags
- ;; configure does not allow us to override this variable from the
- ;; command-line. Fortunately, the Makefile does, so provide it here.
+ ;; configure uses a hard-coded search of /usr/include/python* to set
+ ;; this variable, and does not allow us to override it from the
+ ;; command line. Fortunately, the Makefile does, so provide it here.
(list (string-append "PYTHONVERS=python"
,(version-major+minor (package-version python))))
#:phases