summaryrefslogtreecommitdiff
path: root/gnu/packages/sphinx.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-15 11:29:02 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-15 11:43:21 -0400
commit4920f6e634eeecb37b501bdc024dfe0aab849ed0 (patch)
treec7dd5859715071cb602133b67449a29488027f70 /gnu/packages/sphinx.scm
parent513091dbd2eeba138b558f5f9bb1ee6e68eee01d (diff)
parent3d297a0017210f1dd135592efb10846840a8af88 (diff)
Merge branch 'staging' into core-updates
Conflicts resolved in: gnu/local.mk gnu/packages/cmake.scm gnu/packages/glib.scm gnu/packages/gnome.scm gnu/packages/gtk.scm gnu/packages/sdl.scm pango-next, vala-next and librsvg-bootstrap were removed in the process.
Diffstat (limited to 'gnu/packages/sphinx.scm')
-rw-r--r--gnu/packages/sphinx.scm35
1 files changed, 31 insertions, 4 deletions
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index dc3a90bbcb..85902a8d96 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2015, 2017, 2019, 2020, 2021 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015, 2016, 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
-;;; Copyright © 2016, 2017, 2018, 2019 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2016-2019, 2022 Marius Bakke <marius@gnu.org>
;;; Copyright © 2017 Danny Milosavljevic <dannym+a@scratchpost.org>
;;; Copyright © 2017, 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Frederick M. Muriithi <fredmanglis@gmail.com>
@@ -385,6 +385,33 @@ grid layout. It is no longer maintained and users are encouraged to use
@code{sphinx-design} instead.")
(license license:expat)))
+(define-public python-sphinx-tabs
+ (package
+ (name "python-sphinx-tabs")
+ (version "3.4.1")
+ (home-page "https://github.com/executablebooks/sphinx-tabs")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "sphinx-tabs" version))
+ (sha256
+ (base32
+ "0cmqw5ck2jcxqyf5ibz543idspq0g0fdzxh3fpah1r0nhfg9z86j"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:tests? #f ;TODO: requires sphinx-testing and rinohtype
+ #:phases (modify-phases %standard-phases
+ (add-after 'unpack 'loosen-docutils-requirement
+ (lambda _
+ (substitute* "setup.py"
+ (("docutils~=0\\.18\\.0")
+ "docutils>=0.17.0")))))))
+ (propagated-inputs
+ (list python-docutils python-pygments python-sphinx))
+ (synopsis "Tabbed views for Sphinx")
+ (description
+ "Create tabbed content in Sphinx documentation when building HTML.")
+ (license license:expat)))
+
(define-public python-sphinxcontrib-programoutput
(package
(name "python-sphinxcontrib-programoutput")
@@ -986,7 +1013,7 @@ automated way to document command-line programs. It scans
(define-public python-sphinx-theme-builder
(package
(name "python-sphinx-theme-builder")
- (version "0.2.0a14")
+ (version "0.2.0b1")
(source
(origin
(method git-fetch) ;no tests in pypi archive
@@ -996,7 +1023,7 @@ automated way to document command-line programs. It scans
(file-name (git-file-name name version))
(sha256
(base32
- "1brqp34q716gglliallbgq4m63hl3nk8j6w8wcl8f2vvnkch6v98"))))
+ "15gvwzd4l3wcmd6fns8xvv44yzxmamr1nfn28mp12sdw2y10v2ba"))))
(build-system python-build-system)
(arguments
(list
@@ -1023,7 +1050,7 @@ automated way to document command-line programs. It scans
python-click
python-nodeenv
python-packaging
- python-pep621
+ python-pyproject-metadata
python-rich
python-sphinx-autobuild
python-tomli))