summaryrefslogtreecommitdiff
path: root/gnu/packages/spice.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-02-16 12:00:25 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-02-25 14:46:54 -0500
commit27ae83f5f044a0aa80d804b576c397f9596b95c4 (patch)
treee8fb5316cc5fae40a4d6dc684345e9776360c306 /gnu/packages/spice.scm
parent9582f49a0c9063f3668ff3d16fd4c1a5ee8071eb (diff)
gnu: spice-gtk: Enable support for polkit, webdav and others.
* gnu/packages/spice.scm (spice-gtk) [arguments]: Add the correct-polkit-dir and fake-pkexec phases. [inputs]: Add acl, cyrus-sasl, libcap-ng, polkit and usbutils. [propagated-inputs]: Add libcacard and phodav. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/spice.scm')
-rw-r--r--gnu/packages/spice.scm21
1 files changed, 19 insertions, 2 deletions
diff --git a/gnu/packages/spice.scm b/gnu/packages/spice.scm
index 1654ae141e..62d1d50e5b 100644
--- a/gnu/packages/spice.scm
+++ b/gnu/packages/spice.scm
@@ -22,6 +22,8 @@
(define-module (gnu packages spice)
#:use-module (gnu packages)
+ #:use-module (gnu packages acl)
+ #:use-module (gnu packages admin)
#:use-module (gnu packages autotools)
#:use-module (gnu packages base)
#:use-module (gnu packages bash)
@@ -39,6 +41,7 @@
#:use-module (gnu packages nss)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages polkit)
#:use-module (gnu packages pulseaudio)
#:use-module (gnu packages python)
#:use-module (gnu packages python-build)
@@ -156,6 +159,13 @@ which allows users to view a desktop computing environment.")
((".*'session.c',.*") "")
(("tests_sources \\+= 'cd-emu.c'" all)
(string-append "# " all)))))
+ (add-before 'configure 'correct-polkit-dir
+ (lambda _
+ (substitute* "meson.build"
+ (("d.get_variable\\(pkgconfig: 'policydir')")
+ (string-append "'" #$output "/share/polkit-1/actions'")))))
+ (add-before 'install 'fake-pkexec
+ (lambda _ (setenv "PKEXEC_UID" "-1")))
(add-after 'install 'wrap-spicy
(lambda* (#:key outputs #:allow-other-keys)
(wrap-program (search-input-file outputs "bin/spicy")
@@ -170,13 +180,18 @@ which allows users to view a desktop computing environment.")
python-six
vala))
(inputs
- (list glib-networking
+ (list cyrus-sasl
+ glib-networking
gobject-introspection
json-glib
+ acl
+ libcap-ng
libepoxy
libxcb
mesa
- pulseaudio))
+ polkit
+ pulseaudio
+ usbutils))
(propagated-inputs
(list gstreamer
gst-plugins-base
@@ -187,8 +202,10 @@ which allows users to view a desktop computing environment.")
gtk+
openssl-1.1
opus
+ libcacard
libjpeg-turbo
lz4
+ phodav
pixman
usbredir))
(synopsis "Gtk client and libraries for SPICE remote desktop servers")