summaryrefslogtreecommitdiff
path: root/gnu/packages/spice.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-02-17 09:35:15 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-02-25 14:46:55 -0500
commitbbc10628b62d9b057b4b77b941c0d8678af9e2a3 (patch)
tree4ca78a3b38821468fbaf195c96d7dd965b621d6d /gnu/packages/spice.scm
parente403096b4ab43d983fe31441ac85cd3b9097ffba (diff)
gnu: spice-gtk: Adjust the default file name of the ACL helper binary.
* gnu/packages/spice.scm (spice-gtk) [arguments]: Add adjust-default-acl-helper-path phase. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/spice.scm')
-rw-r--r--gnu/packages/spice.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/spice.scm b/gnu/packages/spice.scm
index 62d1d50e5b..8d2bed38b2 100644
--- a/gnu/packages/spice.scm
+++ b/gnu/packages/spice.scm
@@ -159,6 +159,16 @@ which allows users to view a desktop computing environment.")
((".*'session.c',.*") "")
(("tests_sources \\+= 'cd-emu.c'" all)
(string-append "# " all)))))
+ (add-after 'unpack 'adjust-default-acl-helper-path
+ (lambda _
+ ;; The USB ACL helper used to allow USB redirection as a
+ ;; non-privileged user needs to be setuid, as configured by the
+ ;; gnome-desktop-service-type. A user can still change the
+ ;; location by specifying the SPICE_USB_ACL_BINARY environment
+ ;; variable.
+ (substitute* "src/usb-acl-helper.c"
+ (("ACL_HELPER_PATH\"/spice-client-glib-usb-acl-helper\"")
+ "\"/run/setuid-programs/spice-client-glib-usb-acl-helper\""))))
(add-before 'configure 'correct-polkit-dir
(lambda _
(substitute* "meson.build"