summaryrefslogtreecommitdiff
path: root/gnu/packages/ssh.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2024-01-17 10:37:40 +0100
committerLudovic Courtès <ludo@gnu.org>2024-01-17 10:37:40 +0100
commita63c2e5f8858968dda1844b87b9024914925257b (patch)
tree6584431d8d0c88cd7c03d006645aa24762dfe1fc /gnu/packages/ssh.scm
parent07b9275490c9a23fd557c4292acaf643fbab20cf (diff)
parent299ce524c9f725549ab5548197cc88b085bba2f4 (diff)
Merge branch 'master' into core-updates
Change-Id: Ide7e5cf1c651f193994c02305b6baa4bea4e165f
Diffstat (limited to 'gnu/packages/ssh.scm')
-rw-r--r--gnu/packages/ssh.scm18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index eec9a68e19..4e67845b90 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -205,7 +205,10 @@ a server that supports the SSH-2 protocol.")
(method url-fetch)
(uri (string-append "mirror://openbsd/OpenSSH/portable/"
"openssh-" version ".tar.gz"))
- (patches (search-patches "openssh-trust-guix-store-directory.patch"))
+ (patches (search-patches "openssh-trust-guix-store-directory.patch"
+ ;; Can be removed with next openssh update
+ ;; https://issues.guix.gnu.org/67948#2
+ "openssh-gcc-13-ppc64le-fzero-call-used-regs.patch"))
(sha256
(base32 "0z3pgam8b4z05lvdb78iv06p204qwl7b94a3cnnwba2mfb0120li"))))
(build-system gnu-build-system)
@@ -325,7 +328,7 @@ Additionally, various channel-specific options can be negotiated.")
(define-public guile-ssh
(package
(name "guile-ssh")
- (version "0.16.3")
+ (version "0.16.4")
(home-page "https://github.com/artyom-poptsov/guile-ssh")
(source (origin
(method git-fetch)
@@ -335,7 +338,7 @@ Additionally, various channel-specific options can be negotiated.")
(file-name (git-file-name name version))
(sha256
(base32
- "0b03aizjdj3g15xfkspgvy8k5jl8bgv4q7gwjwr3l2ibqkrm8vrz"))))
+ "127yhjaywais3h2g3cxhqmhdmqgxf9j1jwb6wzx92j0z7asrjqwr"))))
(build-system gnu-build-system)
(outputs '("out" "debug"))
(arguments
@@ -363,8 +366,7 @@ Additionally, various channel-specific options can be negotiated.")
(parallel-job-count)))
(substitute* (find-files "." "\\.scm$")
(("\"libguile-ssh\"")
- (string-append "\"" lib "/libguile-ssh\"")))
- #t)))
+ (string-append "\"" lib "/libguile-ssh\""))))))
,@(if (%current-target-system)
'()
'((add-before 'check 'fix-guile-path
@@ -372,8 +374,7 @@ Additionally, various channel-specific options can be negotiated.")
(let ((guile (assoc-ref inputs "guile")))
(substitute* "tests/common.scm"
(("/usr/bin/guile")
- (string-append guile "/bin/guile")))
- #t)))))
+ (string-append guile "/bin/guile"))))))))
(add-after 'install 'remove-bin-directory
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -385,8 +386,7 @@ Additionally, various channel-specific options can be negotiated.")
(string-append examples "/ssshd.scm"))
(rename-file (string-append bin "/sssh.scm")
(string-append examples "/sssh.scm"))
- (delete-file-recursively bin)
- #t))))))
+ (delete-file-recursively bin)))))))
(native-inputs (list autoconf
automake
libtool