summaryrefslogtreecommitdiff
path: root/gnu/packages/ssh.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2023-03-02 10:37:28 +0000
committerChristopher Baines <mail@cbaines.net>2023-03-02 10:55:08 +0000
commit7df09ee0ab3e7962ef27859ce87e06a323059284 (patch)
treed81334f742ddcb9a1ee63961ca6410922980af1c /gnu/packages/ssh.scm
parent2ac51ec99b58b50c08ba719a8c7e9dba0330b065 (diff)
parentaf95f2d8f98eb2c8c64954bb2fd0b70838899174 (diff)
Merge remote-tracking branch 'savannah/master' into core-updates
Conflicts: gnu/local.mk gnu/packages/autotools.scm gnu/packages/cmake.scm gnu/packages/gnuzilla.scm gnu/packages/haskell.scm gnu/packages/pdf.scm gnu/packages/python-xyz.scm gnu/packages/samba.scm gnu/packages/tex.scm gnu/packages/tls.scm gnu/packages/wxwidgets.scm
Diffstat (limited to 'gnu/packages/ssh.scm')
-rw-r--r--gnu/packages/ssh.scm90
1 files changed, 80 insertions, 10 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 701b3ea2a1..6b4fd47c0c 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -1,10 +1,10 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012-2022 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012-2023 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015, 2016, 2018, 2019, 2020, 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016, 2019 Leo Famulari <leo@famulari.name>
-;;; Copyright © 2016, 2021 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2016, 2021, 2023 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2016 Christine Lemmer-Webber <cwebber@dustycloud.org>
;;; Copyright © 2017–2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Stefan Reichör <stefan@xsteve.at>
@@ -17,6 +17,7 @@
;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2020, 2021, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021 Brice Waegeneire <brice@waegenei.re>
+;;; Copyright © 2023 Simon Streit <simon@netpanic.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -34,6 +35,7 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages ssh)
+ #:use-module (guix gexp)
#:use-module (gnu packages)
#:use-module (gnu packages admin)
#:use-module (gnu packages autotools)
@@ -130,7 +132,7 @@ file names.
(define-public libssh
(package
(name "libssh")
- (version "0.9.6")
+ (version "0.10.4")
(source (origin
(method url-fetch)
(uri (string-append "https://www.libssh.org/files/"
@@ -138,7 +140,16 @@ file names.
"/libssh-" version ".tar.xz"))
(sha256
(base32
- "16w2mc7pyv9mijjlgacbz8dgczc7ig2m6m70w1pld04vpn2zig46"))))
+ "0zfr9fy4vg1bmz1k836hg9wi20mmaz2sgw61s6464iv1mda2qf87"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; 'PATH_MAX' is undefined on GNU/Hurd; work around it.
+ #~(substitute* (find-files "examples" "\\.c$")
+ (("#include \"examples_common\\.h\"" all)
+ (string-append all "\n"
+ "#ifndef PATH_MAX\n"
+ "# define PATH_MAX 4096\n"
+ "#endif\n"))))))
(build-system cmake-build-system)
(outputs '("out" "debug"))
(arguments
@@ -187,7 +198,7 @@ a server that supports the SSH-2 protocol.")
(define-public openssh
(package
(name "openssh")
- (version "9.1p1")
+ (version "9.2p1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://openbsd/OpenSSH/portable/"
@@ -196,7 +207,7 @@ a server that supports the SSH-2 protocol.")
"openssh-trust-guix-store-directory.patch"))
(sha256
(base32
- "126jzn5pxkf1dgzcb3lzpzab8airg0avnvr3y23kgqp3qw4m1y0r"))))
+ "0ingf6fxzg2fcf6k68bvh0lc460jn0macvf5w585zd2zcpqxnriz"))))
(build-system gnu-build-system)
(native-inputs (list groff pkg-config))
(inputs `(("libedit" ,libedit)
@@ -319,7 +330,7 @@ Additionally, various channel-specific options can be negotiated.")
(define-public guile-ssh
(package
(name "guile-ssh")
- (version "0.16.2")
+ (version "0.16.3")
(home-page "https://github.com/artyom-poptsov/guile-ssh")
(source (origin
(method git-fetch)
@@ -329,7 +340,7 @@ Additionally, various channel-specific options can be negotiated.")
(file-name (git-file-name name version))
(sha256
(base32
- "1rp5y1xjmsxplrzl0yf23g6rdjsw7ryh5pxs4pydpsryjjdwnf84"))))
+ "0b03aizjdj3g15xfkspgvy8k5jl8bgv4q7gwjwr3l2ibqkrm8vrz"))))
(build-system gnu-build-system)
(outputs '("out" "debug"))
(arguments
@@ -696,14 +707,14 @@ manipulating key files.")
(define-public sshpass
(package
(name "sshpass")
- (version "1.09")
+ (version "1.10")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/sshpass/sshpass/"
version "/sshpass-" version ".tar.gz"))
(sha256
- (base32 "1dwzqknpswa8vjlbwsx9rcq1j2a7px9h9i2anh09pzkz0mg6wx3i"))))
+ (base32 "1npfvxxqs77qg6l4s6cn8q3b98zwr9n8rb9vra2n3dfb0g10c4dd"))))
(build-system gnu-build-system)
(home-page "https://sourceforge.net/projects/sshpass/")
(synopsis "Non-interactive password authentication with SSH")
@@ -941,3 +952,62 @@ Ed25519 keys.
@item Modern browsers are supported.
@end itemize")
(license license:expat)))
+
+(define-public x11-ssh-askpass
+ (package
+ (name "x11-ssh-askpass")
+ (version "1.2.4.1")
+ (source
+ (origin
+ (method url-fetch)
+ ;; The project home page seams to be offline.
+ (uri (string-append "https://pkgs.fedoraproject.org/repo/pkgs/openssh/"
+ name "-" version ".tar.gz"
+ "/8f2e41f3f7eaa8543a2440454637f3c3/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32 "124c1frwvdmg4nv8xqv435ibjhj2y8xc1bmfr6i8a8g75b1y63b2"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:tests? #f ;no tests
+ #:make-flags
+ #~(list (string-append "BINDIR=" #$output "/libexec")
+ (string-append "MANDIR=" #$output "/share/man"))
+ #:configure-flags
+ #~(list (string-append "--mandir="
+ "/usr/share/man/test")
+ (string-append "--libexecdir="
+ "/usr/lib/ssh/test")
+ (string-append "--with-app-defaults-dir="
+ "/usr/share/X11/app-defaults/test"))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'configure 'xmkmf
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((imake #$(this-package-native-input "imake")))
+ (invoke "xmkmf")
+ (substitute* "Makefile"
+ ;; These imake variables somehow remain undefined
+ (("DefaultGcc2[[:graph:]]*Opt") "-O2")
+ ;; Reset a few variable defaults that are set in imake
+ ;; templates.
+ ((imake) #$output)
+ (("(MANPATH = )[[:graph:]]*" _ front)
+ (string-append front #$output "/share/man"))))))
+ (add-after 'xmkmf 'make-includes
+ (lambda _
+ (invoke "make" "includes")))
+ (add-after 'install 'install/doc
+ (lambda _
+ (lambda _
+ (invoke "make"
+ (string-append "MANDIR=" #$output "/share/man")
+ "install.man")))))))
+ (native-inputs (list imake))
+ (inputs (list libxt))
+ (home-page "http://www.jmknoble.net/software/x11-ssh-askpass/")
+ (synopsis "Lightweight passphrase dialog for SSH")
+ (description "code{x11-ssh-askpass} is an X11-based pass-phrase dialog for
+use with OpenSSH.")
+ (license license:gpl2+)))