summaryrefslogtreecommitdiff
path: root/gnu/packages/ssh.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2016-07-29 14:18:07 -0400
committerMark H Weaver <mhw@netris.org>2016-07-29 14:18:07 -0400
commit0bab3af0786ffd4caec05a29d7281ac5e5c18b6b (patch)
treed83fd52d0cb72b3a9c21642583d804c8c1865646 /gnu/packages/ssh.scm
parent49d725a108dc33f4eb72faff7cf138c5dd8c64f4 (diff)
parent682a7d23385f709a680049a823bb84e45c922b3c (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/ssh.scm')
-rw-r--r--gnu/packages/ssh.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 61a6a5b9d9..a669ccfc9b 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2016 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -492,3 +493,23 @@ providing shell access to the server system from the client. It provides
both the server daemon and the client application, as well as tools for
manipulating key files.")
(license license:gpl2+)))
+
+(define-public sshpass
+ (package
+ (name "sshpass")
+ (version "1.06")
+ (synopsis "Non-interactive password authentication with SSH")
+ (home-page "https://sourceforge.net/projects/sshpass/")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/sshpass/sshpass/"
+ version "/sshpass-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0q7fblaczb7kwbsz0gdy9267z0sllzgmf0c7z5c9mf88wv74ycn6"))))
+ (build-system gnu-build-system)
+ (description "sshpass is a tool for non-interactivly performing password
+authentication with SSH's so-called @dfn{interactive keyboard password
+authentication}.")
+ (license license:gpl2+)))