summaryrefslogtreecommitdiff
path: root/gnu/packages/ssh.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-01-29 23:02:22 +0100
committerAndreas Enge <andreas@enge.fr>2013-01-29 23:05:35 +0100
commit2fbf053b7b7c24ceb36766e19d630f469d0641ce (patch)
treef3b28afb11759b1f89ab71d2f99d162405f13369 /gnu/packages/ssh.scm
parent2a75d4e664e802d3a3e2ed6455c63f32541559c8 (diff)
gnu: Add libssh2.
* gnu/packages/ssh.scm: New file. * Makefile.am (MODULES): Add it.
Diffstat (limited to 'gnu/packages/ssh.scm')
-rw-r--r--gnu/packages/ssh.scm49
1 files changed, 49 insertions, 0 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
new file mode 100644
index 0000000000..50998794f2
--- /dev/null
+++ b/gnu/packages/ssh.scm
@@ -0,0 +1,49 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages ssh)
+ #:use-module ((guix licenses)
+ #:renamer (symbol-prefix-proc 'license:))
+ #:use-module (gnu packages compression)
+ #:use-module (gnu packages gnupg)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu))
+
+(define-public libssh2
+ (package
+ (name "libssh2")
+ (version "1.4.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://www.libssh2.org/download/libssh2-"
+ version ".tar.gz"))
+ (sha256 (base32
+ "0vdr478dbhbdgnniqmirawjb7mrcxckn4slhhrijxnzrkmgziipa"))))
+ (build-system gnu-build-system)
+ (inputs `(("libgcrypt" ,libgcrypt)
+ ("zlib" ,zlib)))
+ (synopsis "libssh2, a client-side C library implementing the SSH2 protocol")
+ (description
+ "libssh2 is a library intended to allow software developers access to
+the SSH-2 protocol in an easy-to-use self-contained package. It can be built
+into an application to perform many different tasks when communicating with
+a server that supports the SSH-2 protocol.")
+ (license license:bsd-3)
+ (home-page "http://www.libssh2.org/")))