summaryrefslogtreecommitdiff
path: root/gnu/packages/statistics.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2023-05-20 15:03:32 -0300
committerVinicius Monego <monego@posteo.net>2023-06-25 10:43:18 -0300
commit64e5e17d8c3e32a5735c6a616afc18bbcc2729fb (patch)
tree0e0f04de786f011a79753fd5ac7636f1560ca1e6 /gnu/packages/statistics.scm
parentc210dbe43e554c1f0e7dc645c1e2bd3c29505ffc (diff)
gnu: Add python-vega-datasets.
* gnu/packages/statistics.scm (python-vega-datasets): New variable. * gnu/packages/patches/python-vega-datasets-remove-la-riots-code.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it.
Diffstat (limited to 'gnu/packages/statistics.scm')
-rw-r--r--gnu/packages/statistics.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index e025653338..449f1aaf66 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -2026,6 +2026,35 @@ and fast file reading.")
"This package provides tools to export R data as LaTeX and HTML tables.")
(license license:gpl2+)))
+(define-public python-vega-datasets
+ (package
+ (name "python-vega-datasets")
+ (version "0.9.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "vega_datasets" version))
+ (sha256
+ (base32 "1h1zv607mars2j73v8fdwihjh479blqxyw29nhmc73lf40s9iglx"))
+ (modules '((guix build utils)))
+ (patches
+ (search-patches "python-vega-datasets-remove-la-riots-code.patch"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'remove-la-riots-dataset
+ ;; Remove dataset with unclear license.
+ (lambda _
+ (delete-file "vega_datasets/_data/la-riots.csv"))))))
+ (native-inputs (list python-pytest))
+ (propagated-inputs (list python-pandas))
+ (home-page "https://github.com/altair-viz/vega_datasets")
+ (synopsis "Example datasets used by Vega-related projects")
+ (description "This package provides a collection of datasets used in Vega
+and Vega-Lite examples.")
+ (license license:expat)))
+
(define-public python-hdmedians
(package
(name "python-hdmedians")